wxPython configuration failed in version 4.0.1 on KDE Neon 5.11.5

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

wxPython configuration failed in version 4.0.1 on KDE Neon 5.11.5

QWERTY_Code
I am trying to install wxPython on both python 2.7 and 3.6 but they both fail at the same stage. I have included the config.log for the 2.7 install.

I have these prerequisites packages installed:
  • Python 2.7
  • Python 3.6
  • pip for both installs
  • dpkg-dev
  • build-essential
  • libjpeg-dev
  • libtiff-dev
  • libsdl1.2-dev
  • libgstreamer-plugins-base0.10-dev
  • libnotify-dev
  • freeglut3
  • freeglut3-dev
  • libsm-dev
  • libgtk-3-dev
  • libwebkitgtk-3.0-dev
  • libgtk2.0-dev
  • libwebkitgtk-dev
  • libgtk2.0-dev
  • libwebkitgtk-dev

pip for python 2 packages include:

  • alabaster (0.7.10)
  • apipkg (1.4)
  • appdirs (1.4.3)
  • attrs (17.4.0)
  • Automat (0.6.0)
  • Babel (2.5.3)
  • blessings (1.6.1)
  • bpython (0.17)
  • buildtools (1.0.6)
  • certifi (2018.1.18)
  • chardet (3.0.4)
  • constantly (15.1.0)
  • curtsies (0.2.11)
  • docopt (0.6.2)
  • docutils (0.14)
  • execnet (1.5.0)
  • funcsigs (1.0.2)
  • furl (1.0.1)
  • greenlet (0.4.13)
  • hyperlink (17.3.1)
  • idna (2.6)
  • imagesize (0.7.1)
  • incremental (17.5.0)
  • Jinja2 (2.10)
  • MarkupSafe (1.0)
  • numpy (1.14.0)
  • orderedmultidict (0.7.11)
  • pip (9.0.1)
  • pkginfo (1.4.1)
  • pluggy (0.6.0)
  • py (1.5.2)
  • Pygments (2.2.0)
  • pyserial (3.4)
  • pytest (3.4.0)
  • pytest-forked (0.2)
  • pytest-timeout (1.2.1)
  • pytest-xdist (1.22.0)
  • python-dateutil (2.6.1)
  • pytz (2017.3)
  • pyusb (1.0.2)
  • redo (1.6)
  • requests (2.18.4)
  • requests-toolbelt (0.8.0)
  • scipy (1.0.0)
  • setuptools (38.4.0)
  • SimpleCV (1.3)
  • simplejson (3.13.2)
  • six (1.11.0)
  • snowballstemmer (1.2.1)
  • Sphinx (1.6.7)
  • sphinxcontrib-websupport (1.0.1)
  • SQLAlchemy (1.2.2)
  • tqdm (4.19.5)
  • twine (1.9.1)
  • Twisted (17.9.0)
  • typing (3.6.4)
  • urllib3 (1.22)
  • wcwidth (0.1.7)
  • wheel (0.30.0)
  • zope.interface (4.4.3)

hope you can help! :)

--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

config.log (24K) Download Attachment