[wxPython] Installing wxPython on Mandrake 7.0

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[wxPython] Installing wxPython on Mandrake 7.0

Steven Taetzsch
Has anyone install wxPython on Linux Mandrake 7.0?

I downloaded wxPython-2.1.13-1.i386.rpm and tried to install, but it
fails with:

error: failed dependencies:
        libMesaGL.so.3 is needed by wxPython-2.1.13-1
        libMesaGLU.so.3 is needed by wxPython-2.1.13-1

Mandrake has these files in /usr/X11R6/lib

libGL.la*    libGL.so.1.0*    libGLU.la*    libGLU.so.1.2.0*  libGLU.so.3.1.2*
libGL.so.1@  libGL.so.1.2.0*  libGLU.so.1@  libGLU.so.3@

Any help would be appreciated.

Thanks,
Steve


_______________________________________________
wxPython-users maillist  -  [hidden email]
http://starship.python.net/mailman/listinfo/wxpython-users



Reply | Threaded
Open this post in threaded view
|

RE: [wxPython] Installing wxPython on Mandrake 7.0

Jan Reimers-2
> ----------
> From: Steven Taetzsch[SMTP:[hidden email]]
> Sent: Wednesday, February 23, 2000 1:48 PM
> To: [hidden email]
> Subject: [wxPython] Installing wxPython on Mandrake 7.0
>
> Has anyone install wxPython on Linux Mandrake 7.0?
Yes, but I compiled from source.  Works great.

> I downloaded wxPython-2.1.13-1.i386.rpm and tried to install, but it
> fails with:
>
> error: failed dependencies:
> libMesaGL.so.3 is needed by wxPython-2.1.13-1
> libMesaGLU.so.3 is needed by wxPython-2.1.13-1
>
> Mandrake has these files in /usr/X11R6/lib
>
> libGL.la*    libGL.so.1.0*    libGLU.la*    libGLU.so.1.2.0*
> libGLU.so.3.1.2*
> libGL.so.1@  libGL.so.1.2.0*  libGLU.so.1@  libGLU.so.3@
If you don't use openGL, try

rpm -i -nodeps wxPython-2.1.13-1.i386.rpm


> Any help would be appreciated.
>
> Thanks,
> Steve
>
>
> _______________________________________________
> wxPython-users maillist  -  [hidden email]
> http://starship.python.net/mailman/listinfo/wxpython-users
>

_______________________________________________
wxPython-users maillist  -  [hidden email]
http://starship.python.net/mailman/listinfo/wxpython-users



Reply | Threaded
Open this post in threaded view
|

Re: [wxPython] Installing wxPython on Mandrake 7.0

Robin Dunn
In reply to this post by Steven Taetzsch
> Has anyone install wxPython on Linux Mandrake 7.0?
>
> I downloaded wxPython-2.1.13-1.i386.rpm and tried to install, but it
> fails with:
>
> error: failed dependencies:
> libMesaGL.so.3 is needed by wxPython-2.1.13-1
> libMesaGLU.so.3 is needed by wxPython-2.1.13-1
>
> Mandrake has these files in /usr/X11R6/lib
>
> libGL.la*    libGL.so.1.0*    libGLU.la*    libGLU.so.1.2.0*
libGLU.so.3.1.2*
> libGL.so.1@  libGL.so.1.2.0*  libGLU.so.1@  libGLU.so.3@
>
> Any help would be appreciated.
>

The Mesa rpms that I used are in http://alldunn.com/wxPython/dist/others/,
but if you don't need the GLCanvas you can just install the wxPython rpm
with --force or --nodeps to skip the dependency check.

Other options:

Get the sources and build (at least) the glcanvas module yourself.

Mesa is supposed to be binary compatible with GL so you can try making some
links to your GL libraries with the Mesa names...

--
Robin Dunn
Software Craftsman
[hidden email]
http://AllDunn.com/robin/
http://AllDunn.com/wxPython/  Check it out!



_______________________________________________
wxPython-users maillist  -  [hidden email]
http://starship.python.net/mailman/listinfo/wxpython-users