wxPython 4 packages for Debian and Fedora

classic Classic list List threaded Threaded
16 messages Options
Reply | Threaded
Open this post in threaded view
|

wxPython 4 packages for Debian and Fedora

Scott Talbert
Hi all,

For those who prefer to use distribution packages, I'm happy to announce
that wxPython 4 is now an 'apt-get' or 'dnf install' away.  :)

Debian:
wxPython 4 has been accepted into Debian Unstable:
https://tracker.debian.org/pkg/wxpython4.0

The binary package names are python-wxgtk4.0 (for Python 2) and
python3-wxgtk4.0 (for Python 3).  The media module is packaged separately
as python-wxgtk-media4.0/python3-wxgtk-media4.0.

These packages have also been pulled into the upcoming Ubuntu 18.04
release.

Fedora:
The packages have been built in Rawhide and F28 development.  The update
to pull them into F27 is in updates-testing.  It should be pushed within a
week or so.

The package names are:
python2-wxpython4
python2-wxpython4-media (for python 2 media module)
python2-wxpython4-webview (for python 2 webview module)
python3-wxpython4
python3-wxpython4-media (for python 3 media module)
python3-wxpython4-webview (for python 3 webview module)

Note: if you used my COPR packages for Fedora, you might notice that the
package names are different.  The official packages should obsolete the
COPR packages, so those should be removed.  Then you can just remove my
COPR from your repository configuration.

Any questions or bugs, please let me know.

Scott

--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [wxPython-dev] wxPython 4 packages for Debian and Fedora

Mario Lacunza-2
Hi,

nice news!! do you know if the package will be available for Ubuntu 16.04?

Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-02-21 19:48 GMT-05:00 Scott Talbert <[hidden email]>:
Hi all,

For those who prefer to use distribution packages, I'm happy to announce that wxPython 4 is now an 'apt-get' or 'dnf install' away.  :)

Debian:
wxPython 4 has been accepted into Debian Unstable:
https://tracker.debian.org/pkg/wxpython4.0

The binary package names are python-wxgtk4.0 (for Python 2) and python3-wxgtk4.0 (for Python 3).  The media module is packaged separately as python-wxgtk-media4.0/python3-wxgtk-media4.0.

These packages have also been pulled into the upcoming Ubuntu 18.04 release.

Fedora:
The packages have been built in Rawhide and F28 development.  The update to pull them into F27 is in updates-testing.  It should be pushed within a week or so.

The package names are:
python2-wxpython4
python2-wxpython4-media (for python 2 media module)
python2-wxpython4-webview (for python 2 webview module)
python3-wxpython4
python3-wxpython4-media (for python 3 media module)
python3-wxpython4-webview (for python 3 webview module)

Note: if you used my COPR packages for Fedora, you might notice that the package names are different.  The official packages should obsolete the COPR packages, so those should be removed.  Then you can just remove my COPR from your repository configuration.

Any questions or bugs, please let me know.

Scott

--
You received this message because you are subscribed to the Google Groups "wxPython-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [wxPython-dev] wxPython 4 packages for Debian and Fedora

Scott Talbert
I can't find a clear answer on whether there is a process for adding new
packages to Ubuntu stable releases.  My guess is probably not, unless it
is a high priority feature.

Would a PPA be of interest for 16.04?  That would probably be doable
without a lot of effort.

On Wed, 21 Feb 2018, Mario Lacunza wrote:

> Hi,
>
> nice news!! do you know if the package will be available for Ubuntu 16.04?
>
> Saludos / Best regards
>
> Mario Lacunza
> Email:: [hidden email]
> Personal Website:: http://www.lacunza.biz/
> Hosting:: http://mlv-host.com/
> Skype: mlacunzav
>
> Lima - Peru
>
> 2018-02-21 19:48 GMT-05:00 Scott Talbert <[hidden email]>:
>       Hi all,
>
>       For those who prefer to use distribution packages, I'm happy
>       to announce that wxPython 4 is now an 'apt-get' or 'dnf
>       install' away.  :)
>
>       Debian:
>       wxPython 4 has been accepted into Debian Unstable:
>       https://tracker.debian.org/pkg/wxpython4.0
>
>       The binary package names are python-wxgtk4.0 (for Python 2)
>       and python3-wxgtk4.0 (for Python 3).  The media module is
>       packaged separately as
>       python-wxgtk-media4.0/python3-wxgtk-media4.0.
>
>       These packages have also been pulled into the upcoming Ubuntu
>       18.04 release.
>
>       Fedora:
>       The packages have been built in Rawhide and F28 development. 
>       The update to pull them into F27 is in updates-testing.  It
>       should be pushed within a week or so.
>
>       The package names are:
>       python2-wxpython4
>       python2-wxpython4-media (for python 2 media module)
>       python2-wxpython4-webview (for python 2 webview module)
>       python3-wxpython4
>       python3-wxpython4-media (for python 3 media module)
>       python3-wxpython4-webview (for python 3 webview module)
>
>       Note: if you used my COPR packages for Fedora, you might
>       notice that the package names are different.  The official
>       packages should obsolete the COPR packages, so those should be
>       removed.  Then you can just remove my COPR from your
>       repository configuration.
>
>       Any questions or bugs, please let me know.
>
>       Scott
>
>       --
>       You received this message because you are subscribed to the
>       Google Groups "wxPython-dev" group.
>       To unsubscribe from this group and stop receiving emails from
>       it, send an email to
>       [hidden email].
>       For more options, visit https://groups.google.com/d/optout.
>
>
> --
> You received this message because you are subscribed to the Google Groups
> "wxPython-users" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [hidden email].
> For more options, visit https://groups.google.com/d/optout.
>
>
--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [wxPython-dev] wxPython 4 packages for Debian and Fedora

Mario Lacunza-2
No, for stable as far I know only Ubuntu staff can add a package into it. So a PPA will be great!  I can test it in my box if you want (Ubuntu 16.04 64bits) let me know.

Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-02-21 23:24 GMT-05:00 Scott Talbert <[hidden email]>:
I can't find a clear answer on whether there is a process for adding new packages to Ubuntu stable releases.  My guess is probably not, unless it is a high priority feature.

Would a PPA be of interest for 16.04?  That would probably be doable without a lot of effort.


On Wed, 21 Feb 2018, Mario Lacunza wrote:

Hi,

nice news!! do you know if the package will be available for Ubuntu 16.04?

Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-02-21 19:48 GMT-05:00 Scott Talbert <[hidden email]>:
      Hi all,

      For those who prefer to use distribution packages, I'm happy
      to announce that wxPython 4 is now an 'apt-get' or 'dnf
      install' away.  :)

      Debian:
      wxPython 4 has been accepted into Debian Unstable:
      https://tracker.debian.org/pkg/wxpython4.0

      The binary package names are python-wxgtk4.0 (for Python 2)
      and python3-wxgtk4.0 (for Python 3).  The media module is
      packaged separately as
      python-wxgtk-media4.0/python3-wxgtk-media4.0.

      These packages have also been pulled into the upcoming Ubuntu
      18.04 release.

      Fedora:
      The packages have been built in Rawhide and F28 development. 
      The update to pull them into F27 is in updates-testing.  It
      should be pushed within a week or so.

      The package names are:
      python2-wxpython4
      python2-wxpython4-media (for python 2 media module)
      python2-wxpython4-webview (for python 2 webview module)
      python3-wxpython4
      python3-wxpython4-media (for python 3 media module)
      python3-wxpython4-webview (for python 3 webview module)

      Note: if you used my COPR packages for Fedora, you might
      notice that the package names are different.  The official
      packages should obsolete the COPR packages, so those should be
      removed.  Then you can just remove my COPR from your
      repository configuration.

      Any questions or bugs, please let me know.

      Scott

      --
      You received this message because you are subscribed to the
      Google Groups "wxPython-dev" group.
      To unsubscribe from this group and stop receiving emails from
      it, send an email to
      [hidden email].
      For more options, visit https://groups.google.com/d/optout.


--
You received this message because you are subscribed to the Google Groups
"wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to [hidden email].
For more options, visit https://groups.google.com/d/optout.



--
You received this message because you are subscribed to the Google Groups "wxPython-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [wxPython-dev] wxPython 4 packages for Debian and Fedora

Scott Talbert
Okay, here's a PPA with a build for 16.04.  Let me know if you have any
issues with it.

https://launchpad.net/~swt-techie/+archive/ubuntu/wxpython4

On Thu, 22 Feb 2018, Mario Lacunza wrote:

> No, for stable as far I know only Ubuntu staff can add a package into it. So
> a PPA will be great!  I can test it in my box if you want (Ubuntu 16.04
> 64bits) let me know.
>
> Saludos / Best regards
>
> Mario Lacunza
> Email:: [hidden email]
> Personal Website:: http://www.lacunza.biz/
> Hosting:: http://mlv-host.com/
> Skype: mlacunzav
>
> Lima - Peru
>
> 2018-02-21 23:24 GMT-05:00 Scott Talbert <[hidden email]>:
>       I can't find a clear answer on whether there is a process for
>       adding new packages to Ubuntu stable releases.  My guess is
>       probably not, unless it is a high priority feature.
>
>       Would a PPA be of interest for 16.04?  That would probably be
>       doable without a lot of effort.
>
>       On Wed, 21 Feb 2018, Mario Lacunza wrote:
>
>       Hi,
>
>       nice news!! do you know if the package will be available
>       for Ubuntu 16.04?
>
>       Saludos / Best regards
>
>       Mario Lacunza
>       Email:: [hidden email]
>       Personal Website:: http://www.lacunza.biz/
>       Hosting:: http://mlv-host.com/
>       Skype: mlacunzav
>
>       Lima - Peru
>
>       2018-02-21 19:48 GMT-05:00 Scott Talbert <[hidden email]>:
>             Hi all,
>
>             For those who prefer to use distribution packages,
>       I'm happy
>             to announce that wxPython 4 is now an 'apt-get' or
>       'dnf
>             install' away.  :)
>
>             Debian:
>             wxPython 4 has been accepted into Debian Unstable:
>             https://tracker.debian.org/pkg/wxpython4.0
>
>             The binary package names are python-wxgtk4.0 (for
>       Python 2)
>             and python3-wxgtk4.0 (for Python 3).  The media
>       module is
>             packaged separately as
>             python-wxgtk-media4.0/python3-wxgtk-media4.0.
>
>             These packages have also been pulled into the
>       upcoming Ubuntu
>             18.04 release.
>
>             Fedora:
>             The packages have been built in Rawhide and F28
>       development. 
>             The update to pull them into F27 is in
>       updates-testing.  It
>             should be pushed within a week or so.
>
>             The package names are:
>             python2-wxpython4
>             python2-wxpython4-media (for python 2 media module)
>             python2-wxpython4-webview (for python 2 webview
>       module)
>             python3-wxpython4
>             python3-wxpython4-media (for python 3 media module)
>             python3-wxpython4-webview (for python 3 webview
>       module)
>
>             Note: if you used my COPR packages for Fedora, you
>       might
>             notice that the package names are different.  The
>       official
>             packages should obsolete the COPR packages, so those
>       should be
>             removed.  Then you can just remove my COPR from your
>             repository configuration.
>
>             Any questions or bugs, please let me know.
>
>             Scott
>
>             --
>             You received this message because you are subscribed
>       to the
>             Google Groups "wxPython-dev" group.
>             To unsubscribe from this group and stop receiving
>       emails from
>             it, send an email to
>             [hidden email].
>             For more options, visit
>       https://groups.google.com/d/optout.
>
>
>       --
>       You received this message because you are subscribed to
>       the Google Groups
> "wxPython-users" group.
> To unsubscribe from this group and stop receiving emails from
> it, send an
> email to [hidden email].
> For more options, visit https://groups.google.com/d/optout.
>
>
>
> --
> You received this message because you are subscribed to the Google
> Groups "wxPython-dev" group.
> To unsubscribe from this group and stop receiving emails from it, send
> an email to [hidden email].
> For more options, visit https://groups.google.com/d/optout.
>
>
> --
> You received this message because you are subscribed to the Google Groups
> "wxPython-dev" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [hidden email].
> For more options, visit https://groups.google.com/d/optout.
>
>
--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [wxPython-dev] wxPython 4 packages for Debian and Fedora

Mario Lacunza-2
Hi,

Amazing!! I just add your PPA but when I try to install the package the system cant find it.  thanks!

mario@mario-lenovo:~$ sudo apt-get install wxpython4.0
[sudo] password for mario:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias      
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete wxpython4.0
E: No se pudo encontrar ningún paquete usando «*» con «wxpython4.0»
E: No se pudo encontrar ningún paquete con la expresión regular «wxpython4.0»



Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-02-28 23:49 GMT-05:00 Scott Talbert <[hidden email]>:
Okay, here's a PPA with a build for 16.04.  Let me know if you have any issues with it.

https://launchpad.net/~swt-techie/+archive/ubuntu/wxpython4


On Thu, 22 Feb 2018, Mario Lacunza wrote:

No, for stable as far I know only Ubuntu staff can add a package into it. So
a PPA will be great!  I can test it in my box if you want (Ubuntu 16.04
64bits) let me know.

Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-02-21 23:24 GMT-05:00 Scott Talbert <[hidden email]>:
      I can't find a clear answer on whether there is a process for
      adding new packages to Ubuntu stable releases.  My guess is
      probably not, unless it is a high priority feature.

      Would a PPA be of interest for 16.04?  That would probably be
      doable without a lot of effort.

      On Wed, 21 Feb 2018, Mario Lacunza wrote:

      Hi,

      nice news!! do you know if the package will be available
      for Ubuntu 16.04?

      Saludos / Best regards

      Mario Lacunza
      Email:: [hidden email]
      Personal Website:: http://www.lacunza.biz/
      Hosting:: http://mlv-host.com/
      Skype: mlacunzav

      Lima - Peru

      2018-02-21 19:48 GMT-05:00 Scott Talbert <[hidden email]>:
            Hi all,

            For those who prefer to use distribution packages,
      I'm happy
            to announce that wxPython 4 is now an 'apt-get' or
      'dnf
            install' away.  :)

            Debian:
            wxPython 4 has been accepted into Debian Unstable:
            https://tracker.debian.org/pkg/wxpython4.0

            The binary package names are python-wxgtk4.0 (for
      Python 2)
            and python3-wxgtk4.0 (for Python 3).  The media
      module is
            packaged separately as
            python-wxgtk-media4.0/python3-wxgtk-media4.0.

            These packages have also been pulled into the
      upcoming Ubuntu
            18.04 release.

            Fedora:
            The packages have been built in Rawhide and F28
      development. 
            The update to pull them into F27 is in
      updates-testing.  It
            should be pushed within a week or so.

            The package names are:
            python2-wxpython4
            python2-wxpython4-media (for python 2 media module)
            python2-wxpython4-webview (for python 2 webview
      module)
            python3-wxpython4
            python3-wxpython4-media (for python 3 media module)
            python3-wxpython4-webview (for python 3 webview
      module)

            Note: if you used my COPR packages for Fedora, you
      might
            notice that the package names are different.  The
      official
            packages should obsolete the COPR packages, so those
      should be
            removed.  Then you can just remove my COPR from your
            repository configuration.

            Any questions or bugs, please let me know.

            Scott

            --
            You received this message because you are subscribed
      to the
            Google Groups "wxPython-dev" group.
            To unsubscribe from this group and stop receiving
      emails from
            it, send an email to
            [hidden email].
            For more options, visit
      https://groups.google.com/d/optout.


      --
      You received this message because you are subscribed to
      the Google Groups
"wxPython-users" group.
To unsubscribe from this group and stop receiving emails from
it, send an
email to [hidden email].
For more options, visit https://groups.google.com/d/optout.



--
You received this message because you are subscribed to the Google
Groups "wxPython-dev" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.


--
You received this message because you are subscribed to the Google Groups
"wxPython-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to [hidden email].
For more options, visit https://groups.google.com/d/optout.



--
You received this message because you are subscribed to the Google Groups "wxPython-dev" group.

To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [wxPython-dev] wxPython 4 packages for Debian and Fedora

Scott Talbert
That's the source package name.  The binary package names are:

python-wxgtk4.0 (Python 2 main package)
python-wxgtk-media4.0 (Python 2 media module)
python3-wxgtk4.0 (Python 3 main package)
python3-wxgtk-media4.0 (Python 2 media module)

On Thu, 1 Mar 2018, Mario Lacunza wrote:

> Hi,
>
> Amazing!! I just add your PPA but when I try to install the package the
> system cant find it.  thanks!
>
> mario@mario-lenovo:~$ sudo apt-get install wxpython4.0
> [sudo] password for mario:
> Leyendo lista de paquetes... Hecho
> Creando árbol de dependencias      
> Leyendo la información de estado... Hecho
> E: No se ha podido localizar el paquete wxpython4.0
> E: No se pudo encontrar ningún paquete usando «*» con «wxpython4.0»
> E: No se pudo encontrar ningún paquete con la expresión regular
> «wxpython4.0»
>
>
>
> Saludos / Best regards
>
> Mario Lacunza
> Email:: [hidden email]
> Personal Website:: http://www.lacunza.biz/
> Hosting:: http://mlv-host.com/
> Skype: mlacunzav
>
> Lima - Peru
>
> 2018-02-28 23:49 GMT-05:00 Scott Talbert <[hidden email]>:
>       Okay, here's a PPA with a build for 16.04.  Let me know if you
>       have any issues with it.
>
>       https://launchpad.net/~swt-techie/+archive/ubuntu/wxpython4
>
>       On Thu, 22 Feb 2018, Mario Lacunza wrote:
>
>             No, for stable as far I know only Ubuntu staff can
>             add a package into it. So
>             a PPA will be great!  I can test it in my box if you
>             want (Ubuntu 16.04
>             64bits) let me know.
>
>             Saludos / Best regards
>
>             Mario Lacunza
>             Email:: [hidden email]
>             Personal Website:: http://www.lacunza.biz/
>             Hosting:: http://mlv-host.com/
>             Skype: mlacunzav
>
>             Lima - Peru
>
>             2018-02-21 23:24 GMT-05:00 Scott Talbert
>             <[hidden email]>:
>                   I can't find a clear answer on whether there
>             is a process for
>                   adding new packages to Ubuntu stable
>             releases.  My guess is
>                   probably not, unless it is a high priority
>             feature.
>
>                   Would a PPA be of interest for 16.04?  That
>             would probably be
>                   doable without a lot of effort.
>
>                   On Wed, 21 Feb 2018, Mario Lacunza wrote:
>
>                   Hi,
>
>                   nice news!! do you know if the package will be
>             available
>                   for Ubuntu 16.04?
>
>                   Saludos / Best regards
>
>                   Mario Lacunza
>                   Email:: [hidden email]
>                   Personal Website:: http://www.lacunza.biz/
>                   Hosting:: http://mlv-host.com/
>                   Skype: mlacunzav
>
>                   Lima - Peru
>
>                   2018-02-21 19:48 GMT-05:00 Scott Talbert
>             <[hidden email]>:
>                         Hi all,
>
>                         For those who prefer to use distribution
>             packages,
>                   I'm happy
>                         to announce that wxPython 4 is now an
>             'apt-get' or
>                   'dnf
>                         install' away.  :)
>
>                         Debian:
>                         wxPython 4 has been accepted into Debian
>             Unstable:
>                        
>             https://tracker.debian.org/pkg/wxpython4.0
>
>                         The binary package names are
>             python-wxgtk4.0 (for
>                   Python 2)
>                         and python3-wxgtk4.0 (for Python 3). 
>             The media
>                   module is
>                         packaged separately as
>                        
>             python-wxgtk-media4.0/python3-wxgtk-media4.0.
>
>                         These packages have also been pulled
>             into the
>                   upcoming Ubuntu
>                         18.04 release.
>
>                         Fedora:
>                         The packages have been built in Rawhide
>             and F28
>                   development. 
>                         The update to pull them into F27 is in
>                   updates-testing.  It
>                         should be pushed within a week or so.
>
>                         The package names are:
>                         python2-wxpython4
>                         python2-wxpython4-media (for python 2
>             media module)
>                         python2-wxpython4-webview (for python 2
>             webview
>                   module)
>                         python3-wxpython4
>                         python3-wxpython4-media (for python 3
>             media module)
>                         python3-wxpython4-webview (for python 3
>             webview
>                   module)
>
>                         Note: if you used my COPR packages for
>             Fedora, you
>                   might
>                         notice that the package names are
>             different.  The
>                   official
>                         packages should obsolete the COPR
>             packages, so those
>                   should be
>                         removed.  Then you can just remove my
>             COPR from your
>                         repository configuration.
>
>                         Any questions or bugs, please let me
>             know.
>
>                         Scott
>
>                         --
>                         You received this message because you
>             are subscribed
>                   to the
>                         Google Groups "wxPython-dev" group.
>                         To unsubscribe from this group and stop
>             receiving
>                   emails from
>                         it, send an email to
>                        
>             [hidden email].
>                         For more options, visit
>                   https://groups.google.com/d/optout.
>
>
>                   --
>                   You received this message because you are
>             subscribed to
>                   the Google Groups
>             "wxPython-users" group.
>             To unsubscribe from this group and stop receiving
>             emails from
>             it, send an
>             email to
>             [hidden email].
>             For more options, visit
>             https://groups.google.com/d/optout.
>
>
>
>             --
>             You received this message because you are subscribed
>             to the Google
>             Groups "wxPython-dev" group.
>             To unsubscribe from this group and stop receiving
>             emails from it, send
>             an email to
>             [hidden email].
>             For more options, visit
>             https://groups.google.com/d/optout.
>
>
>             --
>             You received this message because you are subscribed
>             to the Google Groups
>             "wxPython-dev" group.
>             To unsubscribe from this group and stop receiving
>             emails from it, send an
>             email to [hidden email].
>             For more options, visit
>             https://groups.google.com/d/optout.
>
>
>
>       --
> You received this message because you are subscribed to the Google
> Groups "wxPython-dev" group.
> To unsubscribe from this group and stop receiving emails from it, send
> an email to [hidden email].
> For more options, visit https://groups.google.com/d/optout.
>
>
> --
> You received this message because you are subscribed to the Google Groups
> "wxPython-dev" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [hidden email].
> For more options, visit https://groups.google.com/d/optout.
>
>
--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [wxPython-dev] wxPython 4 packages for Debian and Fedora

Mario Lacunza-2
OMG! what an id... LOL! thanks!! working perfect!!

1000 gracias!

Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-03-01 0:35 GMT-05:00 Scott Talbert <[hidden email]>:
That's the source package name.  The binary package names are:

python-wxgtk4.0 (Python 2 main package)
python-wxgtk-media4.0 (Python 2 media module)
python3-wxgtk4.0 (Python 3 main package)
python3-wxgtk-media4.0 (Python 2 media module)


On Thu, 1 Mar 2018, Mario Lacunza wrote:

Hi,

Amazing!! I just add your PPA but when I try to install the package the
system cant find it.  thanks!

mario@mario-lenovo:~$ sudo apt-get install wxpython4.0
[sudo] password for mario:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias      
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete wxpython4.0
E: No se pudo encontrar ningún paquete usando «*» con «wxpython4.0»
E: No se pudo encontrar ningún paquete con la expresión regular
«wxpython4.0»



Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-02-28 23:49 GMT-05:00 Scott Talbert <[hidden email]>:
      Okay, here's a PPA with a build for 16.04.  Let me know if you
      have any issues with it.

      https://launchpad.net/~swt-techie/+archive/ubuntu/wxpython4

      On Thu, 22 Feb 2018, Mario Lacunza wrote:

            No, for stable as far I know only Ubuntu staff can
            add a package into it. So
            a PPA will be great!  I can test it in my box if you
            want (Ubuntu 16.04
            64bits) let me know.

            Saludos / Best regards

            Mario Lacunza
            Email:: [hidden email]
            Personal Website:: http://www.lacunza.biz/
            Hosting:: http://mlv-host.com/
            Skype: mlacunzav

            Lima - Peru

            2018-02-21 23:24 GMT-05:00 Scott Talbert
            <[hidden email]>:
                  I can't find a clear answer on whether there
            is a process for
                  adding new packages to Ubuntu stable
            releases.  My guess is
                  probably not, unless it is a high priority
            feature.

                  Would a PPA be of interest for 16.04?  That
            would probably be
                  doable without a lot of effort.

                  On Wed, 21 Feb 2018, Mario Lacunza wrote:

                  Hi,

                  nice news!! do you know if the package will be
            available
                  for Ubuntu 16.04?

                  Saludos / Best regards

                  Mario Lacunza
                  Email:: [hidden email]
                  Personal Website:: http://www.lacunza.biz/
                  Hosting:: http://mlv-host.com/
                  Skype: mlacunzav

                  Lima - Peru

                  2018-02-21 19:48 GMT-05:00 Scott Talbert
            <[hidden email]>:
                        Hi all,

                        For those who prefer to use distribution
            packages,
                  I'm happy
                        to announce that wxPython 4 is now an
            'apt-get' or
                  'dnf
                        install' away.  :)

                        Debian:
                        wxPython 4 has been accepted into Debian
            Unstable:
                       
            https://tracker.debian.org/pkg/wxpython4.0

                        The binary package names are
            python-wxgtk4.0 (for
                  Python 2)
                        and python3-wxgtk4.0 (for Python 3). 
            The media
                  module is
                        packaged separately as
                       
            python-wxgtk-media4.0/python3-wxgtk-media4.0.

                        These packages have also been pulled
            into the
                  upcoming Ubuntu
                        18.04 release.

                        Fedora:
                        The packages have been built in Rawhide
            and F28
                  development. 
                        The update to pull them into F27 is in
                  updates-testing.  It
                        should be pushed within a week or so.

                        The package names are:
                        python2-wxpython4
                        python2-wxpython4-media (for python 2
            media module)
                        python2-wxpython4-webview (for python 2
            webview
                  module)
                        python3-wxpython4
                        python3-wxpython4-media (for python 3
            media module)
                        python3-wxpython4-webview (for python 3
            webview
                  module)

                        Note: if you used my COPR packages for
            Fedora, you
                  might
                        notice that the package names are
            different.  The
                  official
                        packages should obsolete the COPR
            packages, so those
                  should be
                        removed.  Then you can just remove my
            COPR from your
                        repository configuration.

                        Any questions or bugs, please let me
            know.

                        Scott

                        --
                        You received this message because you
            are subscribed
                  to the
                        Google Groups "wxPython-dev" group.
                        To unsubscribe from this group and stop
            receiving
                  emails from
                        it, send an email to
                       
            [hidden email].
                        For more options, visit
                  https://groups.google.com/d/optout.


                  --
                  You received this message because you are
            subscribed to
                  the Google Groups
            "wxPython-users" group.
            To unsubscribe from this group and stop receiving
            emails from
            it, send an
            email to
            [hidden email].
            For more options, visit
            https://groups.google.com/d/optout.



            --
            You received this message because you are subscribed
            to the Google
            Groups "wxPython-dev" group.
            To unsubscribe from this group and stop receiving
            emails from it, send
            an email to
            [hidden email].
            For more options, visit
            https://groups.google.com/d/optout.


            --
            You received this message because you are subscribed
            to the Google Groups
            "wxPython-dev" group.
            To unsubscribe from this group and stop receiving
            emails from it, send an
            email to [hidden email].
            For more options, visit
            https://groups.google.com/d/optout.



      --
You received this message because you are subscribed to the Google
Groups "wxPython-dev" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.


--
You received this message because you are subscribed to the Google Groups
"wxPython-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to [hidden email].
For more options, visit https://groups.google.com/d/optout.



--
You received this message because you are subscribed to the Google Groups "wxPython-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [wxPython-dev] wxPython 4 packages for Debian and Fedora

Mario Lacunza-2
Hi,

I need to report a bug, please check the attached screenshot, problem with the html2 module.



Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-03-01 1:30 GMT-05:00 Mario Lacunza <[hidden email]>:
OMG! what an id... LOL! thanks!! working perfect!!

1000 gracias!

Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-03-01 0:35 GMT-05:00 Scott Talbert <[hidden email]>:
That's the source package name.  The binary package names are:

python-wxgtk4.0 (Python 2 main package)
python-wxgtk-media4.0 (Python 2 media module)
python3-wxgtk4.0 (Python 3 main package)
python3-wxgtk-media4.0 (Python 2 media module)


On Thu, 1 Mar 2018, Mario Lacunza wrote:

Hi,

Amazing!! I just add your PPA but when I try to install the package the
system cant find it.  thanks!

mario@mario-lenovo:~$ sudo apt-get install wxpython4.0
[sudo] password for mario:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias      
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete wxpython4.0
E: No se pudo encontrar ningún paquete usando «*» con «wxpython4.0»
E: No se pudo encontrar ningún paquete con la expresión regular
«wxpython4.0»



Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-02-28 23:49 GMT-05:00 Scott Talbert <[hidden email]>:
      Okay, here's a PPA with a build for 16.04.  Let me know if you
      have any issues with it.

      https://launchpad.net/~swt-techie/+archive/ubuntu/wxpython4

      On Thu, 22 Feb 2018, Mario Lacunza wrote:

            No, for stable as far I know only Ubuntu staff can
            add a package into it. So
            a PPA will be great!  I can test it in my box if you
            want (Ubuntu 16.04
            64bits) let me know.

            Saludos / Best regards

            Mario Lacunza
            Email:: [hidden email]
            Personal Website:: http://www.lacunza.biz/
            Hosting:: http://mlv-host.com/
            Skype: mlacunzav

            Lima - Peru

            2018-02-21 23:24 GMT-05:00 Scott Talbert
            <[hidden email]>:
                  I can't find a clear answer on whether there
            is a process for
                  adding new packages to Ubuntu stable
            releases.  My guess is
                  probably not, unless it is a high priority
            feature.

                  Would a PPA be of interest for 16.04?  That
            would probably be
                  doable without a lot of effort.

                  On Wed, 21 Feb 2018, Mario Lacunza wrote:

                  Hi,

                  nice news!! do you know if the package will be
            available
                  for Ubuntu 16.04?

                  Saludos / Best regards

                  Mario Lacunza
                  Email:: [hidden email]
                  Personal Website:: http://www.lacunza.biz/
                  Hosting:: http://mlv-host.com/
                  Skype: mlacunzav

                  Lima - Peru

                  2018-02-21 19:48 GMT-05:00 Scott Talbert
            <[hidden email]>:
                        Hi all,

                        For those who prefer to use distribution
            packages,
                  I'm happy
                        to announce that wxPython 4 is now an
            'apt-get' or
                  'dnf
                        install' away.  :)

                        Debian:
                        wxPython 4 has been accepted into Debian
            Unstable:
                       
            https://tracker.debian.org/pkg/wxpython4.0

                        The binary package names are
            python-wxgtk4.0 (for
                  Python 2)
                        and python3-wxgtk4.0 (for Python 3). 
            The media
                  module is
                        packaged separately as
                       
            python-wxgtk-media4.0/python3-wxgtk-media4.0.

                        These packages have also been pulled
            into the
                  upcoming Ubuntu
                        18.04 release.

                        Fedora:
                        The packages have been built in Rawhide
            and F28
                  development. 
                        The update to pull them into F27 is in
                  updates-testing.  It
                        should be pushed within a week or so.

                        The package names are:
                        python2-wxpython4
                        python2-wxpython4-media (for python 2
            media module)
                        python2-wxpython4-webview (for python 2
            webview
                  module)
                        python3-wxpython4
                        python3-wxpython4-media (for python 3
            media module)
                        python3-wxpython4-webview (for python 3
            webview
                  module)

                        Note: if you used my COPR packages for
            Fedora, you
                  might
                        notice that the package names are
            different.  The
                  official
                        packages should obsolete the COPR
            packages, so those
                  should be
                        removed.  Then you can just remove my
            COPR from your
                        repository configuration.

                        Any questions or bugs, please let me
            know.

                        Scott

                        --
                        You received this message because you
            are subscribed
                  to the
                        Google Groups "wxPython-dev" group.
                        To unsubscribe from this group and stop
            receiving
                  emails from
                        it, send an email to
                       
            [hidden email].
                        For more options, visit
                  https://groups.google.com/d/optout.


                  --
                  You received this message because you are
            subscribed to
                  the Google Groups
            "wxPython-users" group.
            To unsubscribe from this group and stop receiving
            emails from
            it, send an
            email to
            [hidden email].
            For more options, visit
            https://groups.google.com/d/optout.



            --
            You received this message because you are subscribed
            to the Google
            Groups "wxPython-dev" group.
            To unsubscribe from this group and stop receiving
            emails from it, send
            an email to
            [hidden email].
            For more options, visit
            https://groups.google.com/d/optout.


            --
            You received this message because you are subscribed
            to the Google Groups
            "wxPython-dev" group.
            To unsubscribe from this group and stop receiving
            emails from it, send an
            email to [hidden email].
            For more options, visit
            https://groups.google.com/d/optout.



      --
You received this message because you are subscribed to the Google
Groups "wxPython-dev" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.


--
You received this message because you are subscribed to the Google Groups
"wxPython-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to [hidden email].
For more options, visit https://groups.google.com/d/optout.



--
You received this message because you are subscribed to the Google Groups "wxPython-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.


--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

Captura de pantalla de 2018-03-21 23-52-21.png (218K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [wxPython-dev] wxPython 4 packages for Debian and Fedora

Scott Talbert
Yes, that's because I'm building against the system wxWidgets, which on
Debian does not (currently) have wxWebView support.  Xenial does, so I can
remove the disabling of html2.  I will fix it.

On Wed, 21 Mar 2018, Mario Lacunza wrote:

> Hi,
>
> I need to report a bug, please check the attached screenshot, problem with
> the html2 module.
>
>
>
> Saludos / Best regards
>
> Mario Lacunza
> Email:: [hidden email]
> Personal Website:: http://www.lacunza.biz/
> Hosting:: http://mlv-host.com/
> Skype: mlacunzav
>
> Lima - Peru
>
> 2018-03-01 1:30 GMT-05:00 Mario Lacunza <[hidden email]>:
>       OMG! what an id... LOL! thanks!! working perfect!!
>
> 1000 gracias!
>
> Saludos / Best regards
>
> Mario Lacunza
> Email:: [hidden email]
> Personal Website:: http://www.lacunza.biz/
> Hosting:: http://mlv-host.com/
> Skype: mlacunzav
>
> Lima - Peru
>
> 2018-03-01 0:35 GMT-05:00 Scott Talbert <[hidden email]>:
>       That's the source package name.  The binary package names
>       are:
>
>       python-wxgtk4.0 (Python 2 main package)
>       python-wxgtk-media4.0 (Python 2 media module)
>       python3-wxgtk4.0 (Python 3 main package)
>       python3-wxgtk-media4.0 (Python 2 media module)
>
>       On Thu, 1 Mar 2018, Mario Lacunza wrote:
>
>             Hi,
>
>             Amazing!! I just add your PPA but when I try
>             to install the package the
>             system cant find it.  thanks!
>
>             mario@mario-lenovo:~$ sudo apt-get install
>             wxpython4.0
>             [sudo] password for mario:
>             Leyendo lista de paquetes... Hecho
>             Creando árbol de dependencias      
>             Leyendo la información de estado... Hecho
>             E: No se ha podido localizar el paquete
>             wxpython4.0
>             E: No se pudo encontrar ningún paquete usando
>             «*» con «wxpython4.0»
>             E: No se pudo encontrar ningún paquete con la
>             expresión regular
>             «wxpython4.0»
>
>
>
>             Saludos / Best regards
>
>             Mario Lacunza
>             Email:: [hidden email]
>             Personal Website:: http://www.lacunza.biz/
>             Hosting:: http://mlv-host.com/
>             Skype: mlacunzav
>
>             Lima - Peru
>
>             2018-02-28 23:49 GMT-05:00 Scott Talbert
>             <[hidden email]>:
>                   Okay, here's a PPA with a build for
>             16.04.  Let me know if you
>                   have any issues with it.
>
>                  
>             https://launchpad.net/~swt-techie/+archive/ubuntu/wxpython4
>
>                   On Thu, 22 Feb 2018, Mario Lacunza
>             wrote:
>
>                         No, for stable as far I know only
>             Ubuntu staff can
>                         add a package into it. So
>                         a PPA will be great!  I can test
>             it in my box if you
>                         want (Ubuntu 16.04
>                         64bits) let me know.
>
>                         Saludos / Best regards
>
>                         Mario Lacunza
>                         Email:: [hidden email]
>                         Personal Website::
>             http://www.lacunza.biz/
>                         Hosting:: http://mlv-host.com/
>                         Skype: mlacunzav
>
>                         Lima - Peru
>
>                         2018-02-21 23:24 GMT-05:00 Scott
>             Talbert
>                         <[hidden email]>:
>                               I can't find a clear answer
>             on whether there
>                         is a process for
>                               adding new packages to
>             Ubuntu stable
>                         releases.  My guess is
>                               probably not, unless it is a
>             high priority
>                         feature.
>
>                               Would a PPA be of interest
>             for 16.04?  That
>                         would probably be
>                               doable without a lot of
>             effort.
>
>                               On Wed, 21 Feb 2018, Mario
>             Lacunza wrote:
>
>                               Hi,
>
>                               nice news!! do you know if
>             the package will be
>                         available
>                               for Ubuntu 16.04?
>
>                               Saludos / Best regards
>
>                               Mario Lacunza
>                               Email:: [hidden email]
>                               Personal Website::
>             http://www.lacunza.biz/
>                               Hosting::
>             http://mlv-host.com/
>                               Skype: mlacunzav
>
>                               Lima - Peru
>
>                               2018-02-21 19:48 GMT-05:00
>             Scott Talbert
>                         <[hidden email]>:
>                                     Hi all,
>
>                                     For those who prefer
>             to use distribution
>                         packages,
>                               I'm happy
>                                     to announce that
>             wxPython 4 is now an
>                         'apt-get' or
>                               'dnf
>                                     install' away.  :)
>
>                                     Debian:
>                                     wxPython 4 has been
>             accepted into Debian
>                         Unstable:
>                                    
>                        
>             https://tracker.debian.org/pkg/wxpython4.0
>
>                                     The binary package
>             names are
>                         python-wxgtk4.0 (for
>                               Python 2)
>                                     and python3-wxgtk4.0
>             (for Python 3). 
>                         The media
>                               module is
>                                     packaged separately as
>                                    
>                        
>             python-wxgtk-media4.0/python3-wxgtk-media4.0.
>
>                                     These packages have
>             also been pulled
>                         into the
>                               upcoming Ubuntu
>                                     18.04 release.
>
>                                     Fedora:
>                                     The packages have been
>             built in Rawhide
>                         and F28
>                               development. 
>                                     The update to pull
>             them into F27 is in
>                               updates-testing.  It
>                                     should be pushed
>             within a week or so.
>
>                                     The package names are:
>                                     python2-wxpython4
>                                    
>             python2-wxpython4-media (for python 2
>                         media module)
>                                    
>             python2-wxpython4-webview (for python 2
>                         webview
>                               module)
>                                     python3-wxpython4
>                                    
>             python3-wxpython4-media (for python 3
>                         media module)
>                                    
>             python3-wxpython4-webview (for python 3
>                         webview
>                               module)
>
>                                     Note: if you used my
>             COPR packages for
>                         Fedora, you
>                               might
>                                     notice that the
>             package names are
>                         different.  The
>                               official
>                                     packages should
>             obsolete the COPR
>                         packages, so those
>                               should be
>                                     removed.  Then you can
>             just remove my
>                         COPR from your
>                                     repository
>             configuration.
>
>                                     Any questions or bugs,
>             please let me
>                         know.
>
>                                     Scott
>
>                                     --
>                                     You received this
>             message because you
>                         are subscribed
>                               to the
>                                     Google Groups
>             "wxPython-dev" group.
>                                     To unsubscribe from
>             this group and stop
>                         receiving
>                               emails from
>                                     it, send an email to
>                                    
>                        
>             [hidden email].
>                                     For more options,
>             visit
>                              
>             https://groups.google.com/d/optout.
>
>
>                               --
>                               You received this message
>             because you are
>                         subscribed to
>                               the Google Groups
>                         "wxPython-users" group.
>                         To unsubscribe from this group and
>             stop receiving
>                         emails from
>                         it, send an
>                         email to
>                        
>             [hidden email].
>                         For more options, visit
>                        
>             https://groups.google.com/d/optout.
>
>
>
>                         --
>                         You received this message because
>             you are subscribed
>                         to the Google
>                         Groups "wxPython-dev" group.
>                         To unsubscribe from this group and
>             stop receiving
>                         emails from it, send
>                         an email to
>                        
>             [hidden email].
>                         For more options, visit
>                        
>             https://groups.google.com/d/optout.
>
>
>                         --
>                         You received this message because
>             you are subscribed
>                         to the Google Groups
>                         "wxPython-dev" group.
>                         To unsubscribe from this group and
>             stop receiving
>                         emails from it, send an
>                         email to
>             [hidden email].
>                         For more options, visit
>                        
>             https://groups.google.com/d/optout.
>
>
>
>                   --
>             You received this message because you are
>             subscribed to the Google
>             Groups "wxPython-dev" group.
>             To unsubscribe from this group and stop
>             receiving emails from it, send
>             an email to
>             [hidden email].
>             For more options, visit
>             https://groups.google.com/d/optout.
>
>
>             --
>             You received this message because you are
>             subscribed to the Google Groups
>             "wxPython-dev" group.
>             To unsubscribe from this group and stop
>             receiving emails from it, send an
>             email to
>             [hidden email].
>             For more options, visit
>             https://groups.google.com/d/optout.
>
>
>
>       --
>       You received this message because you are subscribed to
>       the Google Groups "wxPython-dev" group.
>       To unsubscribe from this group and stop receiving emails
>       from it, send an email to
>       [hidden email].
>       For more options, visit
>       https://groups.google.com/d/optout.
>
>
>
> --
> You received this message because you are subscribed to the Google Groups
> "wxPython-dev" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [hidden email].
> For more options, visit https://groups.google.com/d/optout.
>
>
--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [wxPython-dev] wxPython 4 packages for Debian and Fedora

Mario Lacunza-2
Thanks Scott! Just in case when I compile wxPython in a VirtualEnv all run fine...

Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-03-22 9:05 GMT-05:00 Scott Talbert <[hidden email]>:
Yes, that's because I'm building against the system wxWidgets, which on Debian does not (currently) have wxWebView support.  Xenial does, so I can remove the disabling of html2.  I will fix it.


On Wed, 21 Mar 2018, Mario Lacunza wrote:

Hi,

I need to report a bug, please check the attached screenshot, problem with
the html2 module.



Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-03-01 1:30 GMT-05:00 Mario Lacunza <[hidden email]>:
      OMG! what an id... LOL! thanks!! working perfect!!

1000 gracias!

Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-03-01 0:35 GMT-05:00 Scott Talbert <[hidden email]>:
      That's the source package name.  The binary package names
      are:

      python-wxgtk4.0 (Python 2 main package)
      python-wxgtk-media4.0 (Python 2 media module)
      python3-wxgtk4.0 (Python 3 main package)
      python3-wxgtk-media4.0 (Python 2 media module)

      On Thu, 1 Mar 2018, Mario Lacunza wrote:

            Hi,

            Amazing!! I just add your PPA but when I try
            to install the package the
            system cant find it.  thanks!

            mario@mario-lenovo:~$ sudo apt-get install
            wxpython4.0
            [sudo] password for mario:
            Leyendo lista de paquetes... Hecho
            Creando árbol de dependencias      
            Leyendo la información de estado... Hecho
            E: No se ha podido localizar el paquete
            wxpython4.0
            E: No se pudo encontrar ningún paquete usando
            «*» con «wxpython4.0»
            E: No se pudo encontrar ningún paquete con la
            expresión regular
            «wxpython4.0»



            Saludos / Best regards

            Mario Lacunza
            Email:: [hidden email]
            Personal Website:: http://www.lacunza.biz/
            Hosting:: http://mlv-host.com/
            Skype: mlacunzav

            Lima - Peru

            2018-02-28 23:49 GMT-05:00 Scott Talbert
            <[hidden email]>:
                  Okay, here's a PPA with a build for
            16.04.  Let me know if you
                  have any issues with it.

                 
            https://launchpad.net/~swt-techie/+archive/ubuntu/wxpython4

                  On Thu, 22 Feb 2018, Mario Lacunza
            wrote:

                        No, for stable as far I know only
            Ubuntu staff can
                        add a package into it. So
                        a PPA will be great!  I can test
            it in my box if you
                        want (Ubuntu 16.04
                        64bits) let me know.

                        Saludos / Best regards

                        Mario Lacunza
                        Email:: [hidden email]
                        Personal Website::
            http://www.lacunza.biz/
                        Hosting:: http://mlv-host.com/
                        Skype: mlacunzav

                        Lima - Peru

                        2018-02-21 23:24 GMT-05:00 Scott
            Talbert
                        <[hidden email]>:
                              I can't find a clear answer
            on whether there
                        is a process for
                              adding new packages to
            Ubuntu stable
                        releases.  My guess is
                              probably not, unless it is a
            high priority
                        feature.

                              Would a PPA be of interest
            for 16.04?  That
                        would probably be
                              doable without a lot of
            effort.

                              On Wed, 21 Feb 2018, Mario
            Lacunza wrote:

                              Hi,

                              nice news!! do you know if
            the package will be
                        available
                              for Ubuntu 16.04?

                              Saludos / Best regards

                              Mario Lacunza
                              Email:: [hidden email]
                              Personal Website::
            http://www.lacunza.biz/
                              Hosting::
            http://mlv-host.com/
                              Skype: mlacunzav

                              Lima - Peru

                              2018-02-21 19:48 GMT-05:00
            Scott Talbert
                        <[hidden email]>:
                                    Hi all,

                                    For those who prefer
            to use distribution
                        packages,
                              I'm happy
                                    to announce that
            wxPython 4 is now an
                        'apt-get' or
                              'dnf
                                    install' away.  :)

                                    Debian:
                                    wxPython 4 has been
            accepted into Debian
                        Unstable:
                                   
                       
            https://tracker.debian.org/pkg/wxpython4.0

                                    The binary package
            names are
                        python-wxgtk4.0 (for
                              Python 2)
                                    and python3-wxgtk4.0
            (for Python 3). 
                        The media
                              module is
                                    packaged separately as
                                   
                       
            python-wxgtk-media4.0/python3-wxgtk-media4.0.

                                    These packages have
            also been pulled
                        into the
                              upcoming Ubuntu
                                    18.04 release.

                                    Fedora:
                                    The packages have been
            built in Rawhide
                        and F28
                              development. 
                                    The update to pull
            them into F27 is in
                              updates-testing.  It
                                    should be pushed
            within a week or so.

                                    The package names are:
                                    python2-wxpython4
                                   
            python2-wxpython4-media (for python 2
                        media module)
                                   
            python2-wxpython4-webview (for python 2
                        webview
                              module)
                                    python3-wxpython4
                                   
            python3-wxpython4-media (for python 3
                        media module)
                                   
            python3-wxpython4-webview (for python 3
                        webview
                              module)

                                    Note: if you used my
            COPR packages for
                        Fedora, you
                              might
                                    notice that the
            package names are
                        different.  The
                              official
                                    packages should
            obsolete the COPR
                        packages, so those
                              should be
                                    removed.  Then you can
            just remove my
                        COPR from your
                                    repository
            configuration.

                                    Any questions or bugs,
            please let me
                        know.

                                    Scott

                                    --
                                    You received this
            message because you
                        are subscribed
                              to the
                                    Google Groups
            "wxPython-dev" group.
                                    To unsubscribe from
            this group and stop
                        receiving
                              emails from
                                    it, send an email to
                                   
                       
            [hidden email].
                                    For more options,
            visit
                             
            https://groups.google.com/d/optout.


                              --
                              You received this message
            because you are
                        subscribed to
                              the Google Groups
                        "wxPython-users" group.
                        To unsubscribe from this group and
            stop receiving
                        emails from
                        it, send an
                        email to
                       
            [hidden email].
                        For more options, visit
                       
            https://groups.google.com/d/optout.



                        --
                        You received this message because
            you are subscribed
                        to the Google
                        Groups "wxPython-dev" group.
                        To unsubscribe from this group and
            stop receiving
                        emails from it, send
                        an email to
                       
            [hidden email].
                        For more options, visit
                       
            https://groups.google.com/d/optout.


                        --
                        You received this message because
            you are subscribed
                        to the Google Groups
                        "wxPython-dev" group.
                        To unsubscribe from this group and
            stop receiving
                        emails from it, send an
                        email to
            [hidden email].
                        For more options, visit
                       
            https://groups.google.com/d/optout.



                  --
            You received this message because you are
            subscribed to the Google
            Groups "wxPython-dev" group.
            To unsubscribe from this group and stop
            receiving emails from it, send
            an email to
            [hidden email].
            For more options, visit
            https://groups.google.com/d/optout.


            --
            You received this message because you are
            subscribed to the Google Groups
            "wxPython-dev" group.
            To unsubscribe from this group and stop
            receiving emails from it, send an
            email to
            [hidden email].
            For more options, visit
            https://groups.google.com/d/optout.



      --
      You received this message because you are subscribed to
      the Google Groups "wxPython-dev" group.
      To unsubscribe from this group and stop receiving emails
      from it, send an email to
      [hidden email].
      For more options, visit
      https://groups.google.com/d/optout.



--
You received this message because you are subscribed to the Google Groups
"wxPython-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to [hidden email].
For more options, visit https://groups.google.com/d/optout.



--
You received this message because you are subscribed to the Google Groups "wxPython-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [wxPython-dev] wxPython 4 packages for Debian and Fedora

Mario Lacunza-2
I have another question: every time I got an error (using Eclipse or using console) I see this message:

Error in atexit._run_exitfuncs:

and not even a clue about which file is the problem or the line where the error is founded, is it that new for python3 or something in your compilation?

Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-03-22 22:41 GMT-05:00 Mario Lacunza <[hidden email]>:
Thanks Scott! Just in case when I compile wxPython in a VirtualEnv all run fine...

Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-03-22 9:05 GMT-05:00 Scott Talbert <[hidden email]>:
Yes, that's because I'm building against the system wxWidgets, which on Debian does not (currently) have wxWebView support.  Xenial does, so I can remove the disabling of html2.  I will fix it.


On Wed, 21 Mar 2018, Mario Lacunza wrote:

Hi,

I need to report a bug, please check the attached screenshot, problem with
the html2 module.



Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-03-01 1:30 GMT-05:00 Mario Lacunza <[hidden email]>:
      OMG! what an id... LOL! thanks!! working perfect!!

1000 gracias!

Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-03-01 0:35 GMT-05:00 Scott Talbert <[hidden email]>:
      That's the source package name.  The binary package names
      are:

      python-wxgtk4.0 (Python 2 main package)
      python-wxgtk-media4.0 (Python 2 media module)
      python3-wxgtk4.0 (Python 3 main package)
      python3-wxgtk-media4.0 (Python 2 media module)

      On Thu, 1 Mar 2018, Mario Lacunza wrote:

            Hi,

            Amazing!! I just add your PPA but when I try
            to install the package the
            system cant find it.  thanks!

            mario@mario-lenovo:~$ sudo apt-get install
            wxpython4.0
            [sudo] password for mario:
            Leyendo lista de paquetes... Hecho
            Creando árbol de dependencias      
            Leyendo la información de estado... Hecho
            E: No se ha podido localizar el paquete
            wxpython4.0
            E: No se pudo encontrar ningún paquete usando
            «*» con «wxpython4.0»
            E: No se pudo encontrar ningún paquete con la
            expresión regular
            «wxpython4.0»



            Saludos / Best regards

            Mario Lacunza
            Email:: [hidden email]
            Personal Website:: http://www.lacunza.biz/
            Hosting:: http://mlv-host.com/
            Skype: mlacunzav

            Lima - Peru

            2018-02-28 23:49 GMT-05:00 Scott Talbert
            <[hidden email]>:
                  Okay, here's a PPA with a build for
            16.04.  Let me know if you
                  have any issues with it.

                 
            https://launchpad.net/~swt-techie/+archive/ubuntu/wxpython4

                  On Thu, 22 Feb 2018, Mario Lacunza
            wrote:

                        No, for stable as far I know only
            Ubuntu staff can
                        add a package into it. So
                        a PPA will be great!  I can test
            it in my box if you
                        want (Ubuntu 16.04
                        64bits) let me know.

                        Saludos / Best regards

                        Mario Lacunza
                        Email:: [hidden email]
                        Personal Website::
            http://www.lacunza.biz/
                        Hosting:: http://mlv-host.com/
                        Skype: mlacunzav

                        Lima - Peru

                        2018-02-21 23:24 GMT-05:00 Scott
            Talbert
                        <[hidden email]>:
                              I can't find a clear answer
            on whether there
                        is a process for
                              adding new packages to
            Ubuntu stable
                        releases.  My guess is
                              probably not, unless it is a
            high priority
                        feature.

                              Would a PPA be of interest
            for 16.04?  That
                        would probably be
                              doable without a lot of
            effort.

                              On Wed, 21 Feb 2018, Mario
            Lacunza wrote:

                              Hi,

                              nice news!! do you know if
            the package will be
                        available
                              for Ubuntu 16.04?

                              Saludos / Best regards

                              Mario Lacunza
                              Email:: [hidden email]
                              Personal Website::
            http://www.lacunza.biz/
                              Hosting::
            http://mlv-host.com/
                              Skype: mlacunzav

                              Lima - Peru

                              2018-02-21 19:48 GMT-05:00
            Scott Talbert
                        <[hidden email]>:
                                    Hi all,

                                    For those who prefer
            to use distribution
                        packages,
                              I'm happy
                                    to announce that
            wxPython 4 is now an
                        'apt-get' or
                              'dnf
                                    install' away.  :)

                                    Debian:
                                    wxPython 4 has been
            accepted into Debian
                        Unstable:
                                   
                       
            https://tracker.debian.org/pkg/wxpython4.0

                                    The binary package
            names are
                        python-wxgtk4.0 (for
                              Python 2)
                                    and python3-wxgtk4.0
            (for Python 3). 
                        The media
                              module is
                                    packaged separately as
                                   
                       
            python-wxgtk-media4.0/python3-wxgtk-media4.0.

                                    These packages have
            also been pulled
                        into the
                              upcoming Ubuntu
                                    18.04 release.

                                    Fedora:
                                    The packages have been
            built in Rawhide
                        and F28
                              development. 
                                    The update to pull
            them into F27 is in
                              updates-testing.  It
                                    should be pushed
            within a week or so.

                                    The package names are:
                                    python2-wxpython4
                                   
            python2-wxpython4-media (for python 2
                        media module)
                                   
            python2-wxpython4-webview (for python 2
                        webview
                              module)
                                    python3-wxpython4
                                   
            python3-wxpython4-media (for python 3
                        media module)
                                   
            python3-wxpython4-webview (for python 3
                        webview
                              module)

                                    Note: if you used my
            COPR packages for
                        Fedora, you
                              might
                                    notice that the
            package names are
                        different.  The
                              official
                                    packages should
            obsolete the COPR
                        packages, so those
                              should be
                                    removed.  Then you can
            just remove my
                        COPR from your
                                    repository
            configuration.

                                    Any questions or bugs,
            please let me
                        know.

                                    Scott

                                    --
                                    You received this
            message because you
                        are subscribed
                              to the
                                    Google Groups
            "wxPython-dev" group.
                                    To unsubscribe from
            this group and stop
                        receiving
                              emails from
                                    it, send an email to
                                   
                       
            [hidden email].
                                    For more options,
            visit
                             
            https://groups.google.com/d/optout.


                              --
                              You received this message
            because you are
                        subscribed to
                              the Google Groups
                        "wxPython-users" group.
                        To unsubscribe from this group and
            stop receiving
                        emails from
                        it, send an
                        email to
                       
            [hidden email].
                        For more options, visit
                       
            https://groups.google.com/d/optout.



                        --
                        You received this message because
            you are subscribed
                        to the Google
                        Groups "wxPython-dev" group.
                        To unsubscribe from this group and
            stop receiving
                        emails from it, send
                        an email to
                       
            [hidden email].
                        For more options, visit
                       
            https://groups.google.com/d/optout.


                        --
                        You received this message because
            you are subscribed
                        to the Google Groups
                        "wxPython-dev" group.
                        To unsubscribe from this group and
            stop receiving
                        emails from it, send an
                        email to
            [hidden email].
                        For more options, visit
                       
            https://groups.google.com/d/optout.



                  --
            You received this message because you are
            subscribed to the Google
            Groups "wxPython-dev" group.
            To unsubscribe from this group and stop
            receiving emails from it, send
            an email to
            [hidden email].
            For more options, visit
            https://groups.google.com/d/optout.


            --
            You received this message because you are
            subscribed to the Google Groups
            "wxPython-dev" group.
            To unsubscribe from this group and stop
            receiving emails from it, send an
            email to
            [hidden email].
            For more options, visit
            https://groups.google.com/d/optout.



      --
      You received this message because you are subscribed to
      the Google Groups "wxPython-dev" group.
      To unsubscribe from this group and stop receiving emails
      from it, send an email to
      [hidden email].
      For more options, visit
      https://groups.google.com/d/optout.



--
You received this message because you are subscribed to the Google Groups
"wxPython-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to [hidden email].
For more options, visit https://groups.google.com/d/optout.



--
You received this message because you are subscribed to the Google Groups "wxPython-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.


--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [wxPython-dev] wxPython 4 packages for Debian and Fedora

Scott Talbert
That's the entire content of the error message?

What were you doing when you saw this error?

On Sun, 25 Mar 2018, Mario Lacunza wrote:

> I have another question: every time I got an error (using Eclipse or using
> console) I see this message:
>
> Error in atexit._run_exitfuncs:
>
> and not even a clue about which file is the problem or the line where the
> error is founded, is it that new for python3 or something in your
> compilation?
>
> Saludos / Best regards
>
> Mario Lacunza
> Email:: [hidden email]
> Personal Website:: http://www.lacunza.biz/
> Hosting:: http://mlv-host.com/
> Skype: mlacunzav
>
> Lima - Peru
>
> 2018-03-22 22:41 GMT-05:00 Mario Lacunza <[hidden email]>:
>       Thanks Scott! Just in case when I compile wxPython in a
>       VirtualEnv all run fine...
>
> Saludos / Best regards
>
> Mario Lacunza
> Email:: [hidden email]
> Personal Website:: http://www.lacunza.biz/
> Hosting:: http://mlv-host.com/
> Skype: mlacunzav
>
> Lima - Peru
>
> 2018-03-22 9:05 GMT-05:00 Scott Talbert <[hidden email]>:
>       Yes, that's because I'm building against the system
>       wxWidgets, which on Debian does not (currently) have
>       wxWebView support.  Xenial does, so I can remove the
>       disabling of html2.  I will fix it.
>
>       On Wed, 21 Mar 2018, Mario Lacunza wrote:
>
>             Hi,
>
>             I need to report a bug, please check the
>             attached screenshot, problem with
>             the html2 module.
>
>
>
>             Saludos / Best regards
>
>             Mario Lacunza
>             Email:: [hidden email]
>             Personal Website:: http://www.lacunza.biz/
>             Hosting:: http://mlv-host.com/
>             Skype: mlacunzav
>
>             Lima - Peru
>
>             2018-03-01 1:30 GMT-05:00 Mario Lacunza
>             <[hidden email]>:
>                   OMG! what an id... LOL! thanks!!
>             working perfect!!
>
>             1000 gracias!
>
>             Saludos / Best regards
>
>             Mario Lacunza
>             Email:: [hidden email]
>             Personal Website:: http://www.lacunza.biz/
>             Hosting:: http://mlv-host.com/
>             Skype: mlacunzav
>
>             Lima - Peru
>
>             2018-03-01 0:35 GMT-05:00 Scott Talbert
>             <[hidden email]>:
>                   That's the source package name.  The
>             binary package names
>                   are:
>
>                   python-wxgtk4.0 (Python 2 main package)
>                   python-wxgtk-media4.0 (Python 2 media
>             module)
>                   python3-wxgtk4.0 (Python 3 main
>             package)
>                   python3-wxgtk-media4.0 (Python 2 media
>             module)
>
>                   On Thu, 1 Mar 2018, Mario Lacunza
>             wrote:
>
>                         Hi,
>
>                         Amazing!! I just add your PPA but
>             when I try
>                         to install the package the
>                         system cant find it.  thanks!
>
>                         mario@mario-lenovo:~$ sudo
>             apt-get install
>                         wxpython4.0
>                         [sudo] password for mario:
>                         Leyendo lista de paquetes...
>             Hecho
>                         Creando árbol de
>             dependencias      
>                         Leyendo la información de
>             estado... Hecho
>                         E: No se ha podido localizar el
>             paquete
>                         wxpython4.0
>                         E: No se pudo encontrar ningún
>             paquete usando
>                         «*» con «wxpython4.0»
>                         E: No se pudo encontrar ningún
>             paquete con la
>                         expresión regular
>                         «wxpython4.0»
>
>
>
>                         Saludos / Best regards
>
>                         Mario Lacunza
>                         Email:: [hidden email]
>                         Personal Website::
>             http://www.lacunza.biz/
>                         Hosting:: http://mlv-host.com/
>                         Skype: mlacunzav
>
>                         Lima - Peru
>
>                         2018-02-28 23:49 GMT-05:00 Scott
>             Talbert
>                         <[hidden email]>:
>                               Okay, here's a PPA with a
>             build for
>                         16.04.  Let me know if you
>                               have any issues with it.
>
>                              
>                        
>             https://launchpad.net/~swt-techie/+archive/ubuntu/wxpython4
>
>                               On Thu, 22 Feb 2018, Mario
>             Lacunza
>                         wrote:
>
>                                     No, for stable as far
>             I know only
>                         Ubuntu staff can
>                                     add a package into
>             it. So
>                                     a PPA will be great! 
>             I can test
>                         it in my box if you
>                                     want (Ubuntu 16.04
>                                     64bits) let me know.
>
>                                     Saludos / Best
>             regards
>
>                                     Mario Lacunza
>                                     Email::
>             [hidden email]
>                                     Personal Website::
>                         http://www.lacunza.biz/
>                                     Hosting::
>             http://mlv-host.com/
>                                     Skype: mlacunzav
>
>                                     Lima - Peru
>
>                                     2018-02-21 23:24
>             GMT-05:00 Scott
>                         Talbert
>                                     <[hidden email]>:
>                                           I can't find a
>             clear answer
>                         on whether there
>                                     is a process for
>                                           adding new
>             packages to
>                         Ubuntu stable
>                                     releases.  My guess
>             is
>                                           probably not,
>             unless it is a
>                         high priority
>                                     feature.
>
>                                           Would a PPA be
>             of interest
>                         for 16.04?  That
>                                     would probably be
>                                           doable without
>             a lot of
>                         effort.
>
>                                           On Wed, 21 Feb
>             2018, Mario
>                         Lacunza wrote:
>
>                                           Hi,
>
>                                           nice news!! do
>             you know if
>                         the package will be
>                                     available
>                                           for Ubuntu
>             16.04?
>
>                                           Saludos / Best
>             regards
>
>                                           Mario Lacunza
>                                           Email::
>             [hidden email]
>                                           Personal
>             Website::
>                         http://www.lacunza.biz/
>                                           Hosting::
>                         http://mlv-host.com/
>                                           Skype:
>             mlacunzav
>
>                                           Lima - Peru
>
>                                           2018-02-21
>             19:48 GMT-05:00
>                         Scott Talbert
>                                     <[hidden email]>:
>                                                 Hi all,
>
>                                                 For those
>             who prefer
>                         to use distribution
>                                     packages,
>                                           I'm happy
>                                                 to
>             announce that
>                         wxPython 4 is now an
>                                     'apt-get' or
>                                           'dnf
>                                                 install'
>             away.  :)
>
>                                                 Debian:
>                                                 wxPython
>             4 has been
>                         accepted into Debian
>                                     Unstable:
>                                                
>                                    
>                        
>             https://tracker.debian.org/pkg/wxpython4.0
>
>                                                 The
>             binary package
>                         names are
>                                     python-wxgtk4.0 (for
>                                           Python 2)
>                                                 and
>             python3-wxgtk4.0
>                         (for Python 3). 
>                                     The media
>                                           module is
>                                                 packaged
>             separately as
>                                                
>                                    
>                        
>             python-wxgtk-media4.0/python3-wxgtk-media4.0.
>
>                                                 These
>             packages have
>                         also been pulled
>                                     into the
>                                           upcoming Ubuntu
>                                                 18.04
>             release.
>
>                                                 Fedora:
>                                                 The
>             packages have been
>                         built in Rawhide
>                                     and F28
>                                           development. 
>                                                 The
>             update to pull
>                         them into F27 is in
>                                          
>             updates-testing.  It
>                                                 should be
>             pushed
>                         within a week or so.
>
>                                                 The
>             package names are:
>                                                
>             python2-wxpython4
>                                                
>                         python2-wxpython4-media (for
>             python 2
>                                     media module)
>                                                
>                         python2-wxpython4-webview (for
>             python 2
>                                     webview
>                                           module)
>                                                
>             python3-wxpython4
>                                                
>                         python3-wxpython4-media (for
>             python 3
>                                     media module)
>                                                
>                         python3-wxpython4-webview (for
>             python 3
>                                     webview
>                                           module)
>
>                                                 Note: if
>             you used my
>                         COPR packages for
>                                     Fedora, you
>                                           might
>                                                 notice
>             that the
>                         package names are
>                                     different.  The
>                                           official
>                                                 packages
>             should
>                         obsolete the COPR
>                                     packages, so those
>                                           should be
>                                                 removed. 
>             Then you can
>                         just remove my
>                                     COPR from your
>                                                
>             repository
>                         configuration.
>
>                                                 Any
>             questions or bugs,
>                         please let me
>                                     know.
>
>                                                 Scott
>
>                                                 --
>                                                 You
>             received this
>                         message because you
>                                     are subscribed
>                                           to the
>                                                 Google
>             Groups
>                         "wxPython-dev" group.
>                                                 To
>             unsubscribe from
>                         this group and stop
>                                     receiving
>                                           emails from
>                                                 it, send
>             an email to
>                                                
>                                    
>                        
>             [hidden email].
>                                                 For more
>             options,
>                         visit
>                                          
>                        
>             https://groups.google.com/d/optout.
>
>
>                                           --
>                                           You received
>             this message
>                         because you are
>                                     subscribed to
>                                           the Google
>             Groups
>                                     "wxPython-users"
>             group.
>                                     To unsubscribe from
>             this group and
>                         stop receiving
>                                     emails from
>                                     it, send an
>                                     email to
>                                    
>                        
>             [hidden email].
>                                     For more options,
>             visit
>                                    
>                        
>             https://groups.google.com/d/optout.
>
>
>
>                                     --
>                                     You received this
>             message because
>                         you are subscribed
>                                     to the Google
>                                     Groups "wxPython-dev"
>             group.
>                                     To unsubscribe from
>             this group and
>                         stop receiving
>                                     emails from it, send
>                                     an email to
>                                    
>                        
>             [hidden email].
>                                     For more options,
>             visit
>                                    
>                        
>             https://groups.google.com/d/optout.
>
>
>                                     --
>                                     You received this
>             message because
>                         you are subscribed
>                                     to the Google Groups
>                                     "wxPython-dev" group.
>                                     To unsubscribe from
>             this group and
>                         stop receiving
>                                     emails from it, send
>             an
>                                     email to
>                        
>             [hidden email].
>                                     For more options,
>             visit
>                                    
>                        
>             https://groups.google.com/d/optout.
>
>
>
>                               --
>                         You received this message because
>             you are
>                         subscribed to the Google
>                         Groups "wxPython-dev" group.
>                         To unsubscribe from this group
>             and stop
>                         receiving emails from it, send
>                         an email to
>                        
>             [hidden email].
>                         For more options, visit
>                        
>             https://groups.google.com/d/optout.
>
>
>                         --
>                         You received this message because
>             you are
>                         subscribed to the Google Groups
>                         "wxPython-dev" group.
>                         To unsubscribe from this group
>             and stop
>                         receiving emails from it, send an
>                         email to
>                        
>             [hidden email].
>                         For more options, visit
>                        
>             https://groups.google.com/d/optout.
>
>
>
>                   --
>                   You received this message because you
>             are subscribed to
>                   the Google Groups "wxPython-dev" group.
>                   To unsubscribe from this group and stop
>             receiving emails
>                   from it, send an email to
>                  
>             [hidden email].
>                   For more options, visit
>                   https://groups.google.com/d/optout.
>
>
>
>             --
>             You received this message because you are
>             subscribed to the Google Groups
>             "wxPython-dev" group.
>             To unsubscribe from this group and stop
>             receiving emails from it, send an
>             email to
>             [hidden email].
>             For more options, visit
>             https://groups.google.com/d/optout.
>
>
>
>       --
>       You received this message because you are subscribed to
>       the Google Groups "wxPython-dev" group.
>       To unsubscribe from this group and stop receiving emails
>       from it, send an email to
>       [hidden email].
>       For more options, visit
>       https://groups.google.com/d/optout.
>
>
>
> --
> You received this message because you are subscribed to the Google Groups
> "wxPython-dev" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [hidden email].
> For more options, visit https://groups.google.com/d/optout.
>
>
--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [wxPython-dev] wxPython 4 packages for Debian and Fedora

Mario Lacunza-2
Yes that's all I get. 

I run my program, off course there is an error in my code but with that generic error I all the time need to run the pydev debugger for find it. 

Enviado desde mi celular LG

El dom., 25 de mar. de 2018 22:18, Scott Talbert <[hidden email]> escribió:
That's the entire content of the error message?

What were you doing when you saw this error?

On Sun, 25 Mar 2018, Mario Lacunza wrote:

> I have another question: every time I got an error (using Eclipse or using
> console) I see this message:
>
> Error in atexit._run_exitfuncs:
>
> and not even a clue about which file is the problem or the line where the
> error is founded, is it that new for python3 or something in your
> compilation?
>
> Saludos / Best regards
>
> Mario Lacunza
> Email:: [hidden email]
> Personal Website:: http://www.lacunza.biz/
> Hosting:: http://mlv-host.com/
> Skype: mlacunzav
>
> Lima - Peru
>
> 2018-03-22 22:41 GMT-05:00 Mario Lacunza <[hidden email]>:
>       Thanks Scott! Just in case when I compile wxPython in a
>       VirtualEnv all run fine...
>
> Saludos / Best regards
>
> Mario Lacunza
> Email:: [hidden email]
> Personal Website:: http://www.lacunza.biz/
> Hosting:: http://mlv-host.com/
> Skype: mlacunzav
>
> Lima - Peru
>
> 2018-03-22 9:05 GMT-05:00 Scott Talbert <[hidden email]>:
>       Yes, that's because I'm building against the system
>       wxWidgets, which on Debian does not (currently) have
>       wxWebView support.  Xenial does, so I can remove the
>       disabling of html2.  I will fix it.
>
>       On Wed, 21 Mar 2018, Mario Lacunza wrote:
>
>             Hi,
>
>             I need to report a bug, please check the
>             attached screenshot, problem with
>             the html2 module.
>
>
>
>             Saludos / Best regards
>
>             Mario Lacunza
>             Email:: [hidden email]
>             Personal Website:: http://www.lacunza.biz/
>             Hosting:: http://mlv-host.com/
>             Skype: mlacunzav
>
>             Lima - Peru
>
>             2018-03-01 1:30 GMT-05:00 Mario Lacunza
>             <[hidden email]>:
>                   OMG! what an id... LOL! thanks!!
>             working perfect!!
>
>             1000 gracias!
>
>             Saludos / Best regards
>
>             Mario Lacunza
>             Email:: [hidden email]
>             Personal Website:: http://www.lacunza.biz/
>             Hosting:: http://mlv-host.com/
>             Skype: mlacunzav
>
>             Lima - Peru
>
>             2018-03-01 0:35 GMT-05:00 Scott Talbert
>             <[hidden email]>:
>                   That's the source package name.  The
>             binary package names
>                   are:
>
>                   python-wxgtk4.0 (Python 2 main package)
>                   python-wxgtk-media4.0 (Python 2 media
>             module)
>                   python3-wxgtk4.0 (Python 3 main
>             package)
>                   python3-wxgtk-media4.0 (Python 2 media
>             module)
>
>                   On Thu, 1 Mar 2018, Mario Lacunza
>             wrote:
>
>                         Hi,
>
>                         Amazing!! I just add your PPA but
>             when I try
>                         to install the package the
>                         system cant find it.  thanks!
>
>                         mario@mario-lenovo:~$ sudo
>             apt-get install
>                         wxpython4.0
>                         [sudo] password for mario:
>                         Leyendo lista de paquetes...
>             Hecho
>                         Creando árbol de
>             dependencias      
>                         Leyendo la información de
>             estado... Hecho
>                         E: No se ha podido localizar el
>             paquete
>                         wxpython4.0
>                         E: No se pudo encontrar ningún
>             paquete usando
>                         «*» con «wxpython4.0»
>                         E: No se pudo encontrar ningún
>             paquete con la
>                         expresión regular
>                         «wxpython4.0»
>
>
>
>                         Saludos / Best regards
>
>                         Mario Lacunza
>                         Email:: [hidden email]
>                         Personal Website::
>             http://www.lacunza.biz/
>                         Hosting:: http://mlv-host.com/
>                         Skype: mlacunzav
>
>                         Lima - Peru
>
>                         2018-02-28 23:49 GMT-05:00 Scott
>             Talbert
>                         <[hidden email]>:
>                               Okay, here's a PPA with a
>             build for
>                         16.04.  Let me know if you
>                               have any issues with it.
>
>                              
>                        
>             https://launchpad.net/~swt-techie/+archive/ubuntu/wxpython4
>
>                               On Thu, 22 Feb 2018, Mario
>             Lacunza
>                         wrote:
>
>                                     No, for stable as far
>             I know only
>                         Ubuntu staff can
>                                     add a package into
>             it. So
>                                     a PPA will be great! 
>             I can test
>                         it in my box if you
>                                     want (Ubuntu 16.04
>                                     64bits) let me know.
>
>                                     Saludos / Best
>             regards
>
>                                     Mario Lacunza
>                                     Email::
>             [hidden email]
>                                     Personal Website::
>                         http://www.lacunza.biz/
>                                     Hosting::
>             http://mlv-host.com/
>                                     Skype: mlacunzav
>
>                                     Lima - Peru
>
>                                     2018-02-21 23:24
>             GMT-05:00 Scott
>                         Talbert
>                                     <[hidden email]>:
>                                           I can't find a
>             clear answer
>                         on whether there
>                                     is a process for
>                                           adding new
>             packages to
>                         Ubuntu stable
>                                     releases.  My guess
>             is
>                                           probably not,
>             unless it is a
>                         high priority
>                                     feature.
>
>                                           Would a PPA be
>             of interest
>                         for 16.04?  That
>                                     would probably be
>                                           doable without
>             a lot of
>                         effort.
>
>                                           On Wed, 21 Feb
>             2018, Mario
>                         Lacunza wrote:
>
>                                           Hi,
>
>                                           nice news!! do
>             you know if
>                         the package will be
>                                     available
>                                           for Ubuntu
>             16.04?
>
>                                           Saludos / Best
>             regards
>
>                                           Mario Lacunza
>                                           Email::
>             [hidden email]
>                                           Personal
>             Website::
>                         http://www.lacunza.biz/
>                                           Hosting::
>                         http://mlv-host.com/
>                                           Skype:
>             mlacunzav
>
>                                           Lima - Peru
>
>                                           2018-02-21
>             19:48 GMT-05:00
>                         Scott Talbert
>                                     <[hidden email]>:
>                                                 Hi all,
>
>                                                 For those
>             who prefer
>                         to use distribution
>                                     packages,
>                                           I'm happy
>                                                 to
>             announce that
>                         wxPython 4 is now an
>                                     'apt-get' or
>                                           'dnf
>                                                 install'
>             away.  :)
>
>                                                 Debian:
>                                                 wxPython
>             4 has been
>                         accepted into Debian
>                                     Unstable:
>                                                
>                                    
>                        
>             https://tracker.debian.org/pkg/wxpython4.0
>
>                                                 The
>             binary package
>                         names are
>                                     python-wxgtk4.0 (for
>                                           Python 2)
>                                                 and
>             python3-wxgtk4.0
>                         (for Python 3). 
>                                     The media
>                                           module is
>                                                 packaged
>             separately as
>                                                
>                                    
>                        
>             python-wxgtk-media4.0/python3-wxgtk-media4.0.
>
>                                                 These
>             packages have
>                         also been pulled
>                                     into the
>                                           upcoming Ubuntu
>                                                 18.04
>             release.
>
>                                                 Fedora:
>                                                 The
>             packages have been
>                         built in Rawhide
>                                     and F28
>                                           development. 
>                                                 The
>             update to pull
>                         them into F27 is in
>                                          
>             updates-testing.  It
>                                                 should be
>             pushed
>                         within a week or so.
>
>                                                 The
>             package names are:
>                                                
>             python2-wxpython4
>                                                
>                         python2-wxpython4-media (for
>             python 2
>                                     media module)
>                                                
>                         python2-wxpython4-webview (for
>             python 2
>                                     webview
>                                           module)
>                                                
>             python3-wxpython4
>                                                
>                         python3-wxpython4-media (for
>             python 3
>                                     media module)
>                                                
>                         python3-wxpython4-webview (for
>             python 3
>                                     webview
>                                           module)
>
>                                                 Note: if
>             you used my
>                         COPR packages for
>                                     Fedora, you
>                                           might
>                                                 notice
>             that the
>                         package names are
>                                     different.  The
>                                           official
>                                                 packages
>             should
>                         obsolete the COPR
>                                     packages, so those
>                                           should be
>                                                 removed. 
>             Then you can
>                         just remove my
>                                     COPR from your
>                                                
>             repository
>                         configuration.
>
>                                                 Any
>             questions or bugs,
>                         please let me
>                                     know.
>
>                                                 Scott
>
>                                                 --
>                                                 You
>             received this
>                         message because you
>                                     are subscribed
>                                           to the
>                                                 Google
>             Groups
>                         "wxPython-dev" group.
>                                                 To
>             unsubscribe from
>                         this group and stop
>                                     receiving
>                                           emails from
>                                                 it, send
>             an email to
>                                                
>                                    
>                        
>             [hidden email].
>                                                 For more
>             options,
>                         visit
>                                          
>                        
>             https://groups.google.com/d/optout.
>
>
>                                           --
>                                           You received
>             this message
>                         because you are
>                                     subscribed to
>                                           the Google
>             Groups
>                                     "wxPython-users"
>             group.
>                                     To unsubscribe from
>             this group and
>                         stop receiving
>                                     emails from
>                                     it, send an
>                                     email to
>                                    
>                        
>             [hidden email].
>                                     For more options,
>             visit
>                                    
>                        
>             https://groups.google.com/d/optout.
>
>
>
>                                     --
>                                     You received this
>             message because
>                         you are subscribed
>                                     to the Google
>                                     Groups "wxPython-dev"
>             group.
>                                     To unsubscribe from
>             this group and
>                         stop receiving
>                                     emails from it, send
>                                     an email to
>                                    
>                        
>             [hidden email].
>                                     For more options,
>             visit
>                                    
>                        
>             https://groups.google.com/d/optout.
>
>
>                                     --
>                                     You received this
>             message because
>                         you are subscribed
>                                     to the Google Groups
>                                     "wxPython-dev" group.
>                                     To unsubscribe from
>             this group and
>                         stop receiving
>                                     emails from it, send
>             an
>                                     email to
>                        
>             [hidden email].
>                                     For more options,
>             visit
>                                    
>                        
>             https://groups.google.com/d/optout.
>
>
>
>                               --
>                         You received this message because
>             you are
>                         subscribed to the Google
>                         Groups "wxPython-dev" group.
>                         To unsubscribe from this group
>             and stop
>                         receiving emails from it, send
>                         an email to
>                        
>             [hidden email].
>                         For more options, visit
>                        
>             https://groups.google.com/d/optout.
>
>
>                         --
>                         You received this message because
>             you are
>                         subscribed to the Google Groups
>                         "wxPython-dev" group.
>                         To unsubscribe from this group
>             and stop
>                         receiving emails from it, send an
>                         email to
>                        
>             [hidden email].
>                         For more options, visit
>                        
>             https://groups.google.com/d/optout.
>
>
>
>                   --
>                   You received this message because you
>             are subscribed to
>                   the Google Groups "wxPython-dev" group.
>                   To unsubscribe from this group and stop
>             receiving emails
>                   from it, send an email to
>                  
>             [hidden email].
>                   For more options, visit
>                   https://groups.google.com/d/optout.
>
>
>
>             --
>             You received this message because you are
>             subscribed to the Google Groups
>             "wxPython-dev" group.
>             To unsubscribe from this group and stop
>             receiving emails from it, send an
>             email to
>             [hidden email].
>             For more options, visit
>             https://groups.google.com/d/optout.
>
>
>
>       --
>       You received this message because you are subscribed to
>       the Google Groups "wxPython-dev" group.
>       To unsubscribe from this group and stop receiving emails
>       from it, send an email to
>       [hidden email].
>       For more options, visit
>       https://groups.google.com/d/optout.
>
>
>
> --
> You received this message because you are subscribed to the Google Groups
> "wxPython-dev" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [hidden email].
> For more options, visit https://groups.google.com/d/optout.
>
>

--
You received this message because you are subscribed to the Google Groups "wxPython-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [wxPython-dev] wxPython 4 packages for Debian and Fedora

Scott Talbert
In reply to this post by Mario Lacunza-2
This has been fixed in the PPA build 4.0.1+dfsg-2~ppa1.

Note that the wx.html2 (webview) module is package separately in packages
python-wxgtk-webview4.0 and python3-wxgtk-webview4.0.

Scott

On Wed, 21 Mar 2018, Mario Lacunza wrote:

> Hi,
>
> I need to report a bug, please check the attached screenshot, problem with
> the html2 module.
>
>
>
> Saludos / Best regards
>
> Mario Lacunza
> Email:: [hidden email]
> Personal Website:: http://www.lacunza.biz/
> Hosting:: http://mlv-host.com/
> Skype: mlacunzav
>
> Lima - Peru
>
> 2018-03-01 1:30 GMT-05:00 Mario Lacunza <[hidden email]>:
>       OMG! what an id... LOL! thanks!! working perfect!!
>
> 1000 gracias!
>
> Saludos / Best regards
>
> Mario Lacunza
> Email:: [hidden email]
> Personal Website:: http://www.lacunza.biz/
> Hosting:: http://mlv-host.com/
> Skype: mlacunzav
>
> Lima - Peru
>
> 2018-03-01 0:35 GMT-05:00 Scott Talbert <[hidden email]>:
>       That's the source package name.  The binary package names
>       are:
>
>       python-wxgtk4.0 (Python 2 main package)
>       python-wxgtk-media4.0 (Python 2 media module)
>       python3-wxgtk4.0 (Python 3 main package)
>       python3-wxgtk-media4.0 (Python 2 media module)
>
>       On Thu, 1 Mar 2018, Mario Lacunza wrote:
>
>             Hi,
>
>             Amazing!! I just add your PPA but when I try
>             to install the package the
>             system cant find it.  thanks!
>
>             mario@mario-lenovo:~$ sudo apt-get install
>             wxpython4.0
>             [sudo] password for mario:
>             Leyendo lista de paquetes... Hecho
>             Creando árbol de dependencias      
>             Leyendo la información de estado... Hecho
>             E: No se ha podido localizar el paquete
>             wxpython4.0
>             E: No se pudo encontrar ningún paquete usando
>             «*» con «wxpython4.0»
>             E: No se pudo encontrar ningún paquete con la
>             expresión regular
>             «wxpython4.0»
>
>
>
>             Saludos / Best regards
>
>             Mario Lacunza
>             Email:: [hidden email]
>             Personal Website:: http://www.lacunza.biz/
>             Hosting:: http://mlv-host.com/
>             Skype: mlacunzav
>
>             Lima - Peru
>
>             2018-02-28 23:49 GMT-05:00 Scott Talbert
>             <[hidden email]>:
>                   Okay, here's a PPA with a build for
>             16.04.  Let me know if you
>                   have any issues with it.
>
>                  
>             https://launchpad.net/~swt-techie/+archive/ubuntu/wxpython4
>
>                   On Thu, 22 Feb 2018, Mario Lacunza
>             wrote:
>
>                         No, for stable as far I know only
>             Ubuntu staff can
>                         add a package into it. So
>                         a PPA will be great!  I can test
>             it in my box if you
>                         want (Ubuntu 16.04
>                         64bits) let me know.
>
>                         Saludos / Best regards
>
>                         Mario Lacunza
>                         Email:: [hidden email]
>                         Personal Website::
>             http://www.lacunza.biz/
>                         Hosting:: http://mlv-host.com/
>                         Skype: mlacunzav
>
>                         Lima - Peru
>
>                         2018-02-21 23:24 GMT-05:00 Scott
>             Talbert
>                         <[hidden email]>:
>                               I can't find a clear answer
>             on whether there
>                         is a process for
>                               adding new packages to
>             Ubuntu stable
>                         releases.  My guess is
>                               probably not, unless it is
>             a high priority
>                         feature.
>
>                               Would a PPA be of interest
>             for 16.04?  That
>                         would probably be
>                               doable without a lot of
>             effort.
>
>                               On Wed, 21 Feb 2018, Mario
>             Lacunza wrote:
>
>                               Hi,
>
>                               nice news!! do you know if
>             the package will be
>                         available
>                               for Ubuntu 16.04?
>
>                               Saludos / Best regards
>
>                               Mario Lacunza
>                               Email:: [hidden email]
>                               Personal Website::
>             http://www.lacunza.biz/
>                               Hosting::
>             http://mlv-host.com/
>                               Skype: mlacunzav
>
>                               Lima - Peru
>
>                               2018-02-21 19:48 GMT-05:00
>             Scott Talbert
>                         <[hidden email]>:
>                                     Hi all,
>
>                                     For those who prefer
>             to use distribution
>                         packages,
>                               I'm happy
>                                     to announce that
>             wxPython 4 is now an
>                         'apt-get' or
>                               'dnf
>                                     install' away.  :)
>
>                                     Debian:
>                                     wxPython 4 has been
>             accepted into Debian
>                         Unstable:
>                                    
>                        
>             https://tracker.debian.org/pkg/wxpython4.0
>
>                                     The binary package
>             names are
>                         python-wxgtk4.0 (for
>                               Python 2)
>                                     and python3-wxgtk4.0
>             (for Python 3). 
>                         The media
>                               module is
>                                     packaged separately
>             as
>                                    
>                        
>             python-wxgtk-media4.0/python3-wxgtk-media4.0.
>
>                                     These packages have
>             also been pulled
>                         into the
>                               upcoming Ubuntu
>                                     18.04 release.
>
>                                     Fedora:
>                                     The packages have
>             been built in Rawhide
>                         and F28
>                               development. 
>                                     The update to pull
>             them into F27 is in
>                               updates-testing.  It
>                                     should be pushed
>             within a week or so.
>
>                                     The package names
>             are:
>                                     python2-wxpython4
>                                    
>             python2-wxpython4-media (for python 2
>                         media module)
>                                    
>             python2-wxpython4-webview (for python 2
>                         webview
>                               module)
>                                     python3-wxpython4
>                                    
>             python3-wxpython4-media (for python 3
>                         media module)
>                                    
>             python3-wxpython4-webview (for python 3
>                         webview
>                               module)
>
>                                     Note: if you used my
>             COPR packages for
>                         Fedora, you
>                               might
>                                     notice that the
>             package names are
>                         different.  The
>                               official
>                                     packages should
>             obsolete the COPR
>                         packages, so those
>                               should be
>                                     removed.  Then you
>             can just remove my
>                         COPR from your
>                                     repository
>             configuration.
>
>                                     Any questions or
>             bugs, please let me
>                         know.
>
>                                     Scott
>
>                                     --
>                                     You received this
>             message because you
>                         are subscribed
>                               to the
>                                     Google Groups
>             "wxPython-dev" group.
>                                     To unsubscribe from
>             this group and stop
>                         receiving
>                               emails from
>                                     it, send an email to
>                                    
>                        
>             [hidden email].
>                                     For more options,
>             visit
>                              
>             https://groups.google.com/d/optout.
>
>
>                               --
>                               You received this message
>             because you are
>                         subscribed to
>                               the Google Groups
>                         "wxPython-users" group.
>                         To unsubscribe from this group
>             and stop receiving
>                         emails from
>                         it, send an
>                         email to
>                        
>             [hidden email].
>                         For more options, visit
>                        
>             https://groups.google.com/d/optout.
>
>
>
>                         --
>                         You received this message because
>             you are subscribed
>                         to the Google
>                         Groups "wxPython-dev" group.
>                         To unsubscribe from this group
>             and stop receiving
>                         emails from it, send
>                         an email to
>                        
>             [hidden email].
>                         For more options, visit
>                        
>             https://groups.google.com/d/optout.
>
>
>                         --
>                         You received this message because
>             you are subscribed
>                         to the Google Groups
>                         "wxPython-dev" group.
>                         To unsubscribe from this group
>             and stop receiving
>                         emails from it, send an
>                         email to
>             [hidden email].
>                         For more options, visit
>                        
>             https://groups.google.com/d/optout.
>
>
>
>                   --
>             You received this message because you are
>             subscribed to the Google
>             Groups "wxPython-dev" group.
>             To unsubscribe from this group and stop
>             receiving emails from it, send
>             an email to
>             [hidden email].
>             For more options, visit
>             https://groups.google.com/d/optout.
>
>
>             --
>             You received this message because you are
>             subscribed to the Google Groups
>             "wxPython-dev" group.
>             To unsubscribe from this group and stop
>             receiving emails from it, send an
>             email to
>             [hidden email].
>             For more options, visit
>             https://groups.google.com/d/optout.
>
>
>
>       --
>       You received this message because you are subscribed to
>       the Google Groups "wxPython-dev" group.
>       To unsubscribe from this group and stop receiving emails
>       from it, send an email to
>       [hidden email].
>       For more options, visit
>       https://groups.google.com/d/optout.
>
>
>
> --
> You received this message because you are subscribed to the Google Groups
> "wxPython-dev" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [hidden email].
> For more options, visit https://groups.google.com/d/optout.
>
>
--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: [wxPython-dev] wxPython 4 packages for Debian and Fedora

Mario Lacunza-2
Confirmed!! works perfect now! thanks!

Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-03-25 23:24 GMT-05:00 Scott Talbert <[hidden email]>:
This has been fixed in the PPA build 4.0.1+dfsg-2~ppa1.

Note that the wx.html2 (webview) module is package separately in packages python-wxgtk-webview4.0 and python3-wxgtk-webview4.0.

Scott


On Wed, 21 Mar 2018, Mario Lacunza wrote:

Hi,

I need to report a bug, please check the attached screenshot, problem with
the html2 module.



Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-03-01 1:30 GMT-05:00 Mario Lacunza <[hidden email]>:
      OMG! what an id... LOL! thanks!! working perfect!!

1000 gracias!

Saludos / Best regards

Mario Lacunza
Email:: [hidden email]
Personal Website:: http://www.lacunza.biz/
Hosting:: http://mlv-host.com/
Skype: mlacunzav

Lima - Peru

2018-03-01 0:35 GMT-05:00 Scott Talbert <[hidden email]>:
      That's the source package name.  The binary package names
      are:

      python-wxgtk4.0 (Python 2 main package)
      python-wxgtk-media4.0 (Python 2 media module)
      python3-wxgtk4.0 (Python 3 main package)
      python3-wxgtk-media4.0 (Python 2 media module)

      On Thu, 1 Mar 2018, Mario Lacunza wrote:

            Hi,

            Amazing!! I just add your PPA but when I try
            to install the package the
            system cant find it.  thanks!

            mario@mario-lenovo:~$ sudo apt-get install
            wxpython4.0
            [sudo] password for mario:
            Leyendo lista de paquetes... Hecho
            Creando árbol de dependencias      
            Leyendo la información de estado... Hecho
            E: No se ha podido localizar el paquete
            wxpython4.0
            E: No se pudo encontrar ningún paquete usando
            «*» con «wxpython4.0»
            E: No se pudo encontrar ningún paquete con la
            expresión regular
            «wxpython4.0»



            Saludos / Best regards

            Mario Lacunza
            Email:: [hidden email]
            Personal Website:: http://www.lacunza.biz/
            Hosting:: http://mlv-host.com/
            Skype: mlacunzav

            Lima - Peru

            2018-02-28 23:49 GMT-05:00 Scott Talbert
            <[hidden email]>:
                  Okay, here's a PPA with a build for
            16.04.  Let me know if you
                  have any issues with it.

                 
            https://launchpad.net/~swt-techie/+archive/ubuntu/wxpython4

                  On Thu, 22 Feb 2018, Mario Lacunza
            wrote:

                        No, for stable as far I know only
            Ubuntu staff can
                        add a package into it. So
                        a PPA will be great!  I can test
            it in my box if you
                        want (Ubuntu 16.04
                        64bits) let me know.

                        Saludos / Best regards

                        Mario Lacunza
                        Email:: [hidden email]
                        Personal Website::
            http://www.lacunza.biz/
                        Hosting:: http://mlv-host.com/
                        Skype: mlacunzav

                        Lima - Peru

                        2018-02-21 23:24 GMT-05:00 Scott
            Talbert
                        <[hidden email]>:
                              I can't find a clear answer
            on whether there
                        is a process for
                              adding new packages to
            Ubuntu stable
                        releases.  My guess is
                              probably not, unless it is
            a high priority
                        feature.

                              Would a PPA be of interest
            for 16.04?  That
                        would probably be
                              doable without a lot of
            effort.

                              On Wed, 21 Feb 2018, Mario
            Lacunza wrote:

                              Hi,

                              nice news!! do you know if
            the package will be
                        available
                              for Ubuntu 16.04?

                              Saludos / Best regards

                              Mario Lacunza
                              Email:: [hidden email]
                              Personal Website::
            http://www.lacunza.biz/
                              Hosting::
            http://mlv-host.com/
                              Skype: mlacunzav

                              Lima - Peru

                              2018-02-21 19:48 GMT-05:00
            Scott Talbert
                        <[hidden email]>:
                                    Hi all,

                                    For those who prefer
            to use distribution
                        packages,
                              I'm happy
                                    to announce that
            wxPython 4 is now an
                        'apt-get' or
                              'dnf
                                    install' away.  :)

                                    Debian:
                                    wxPython 4 has been
            accepted into Debian
                        Unstable:
                                   
                       
            https://tracker.debian.org/pkg/wxpython4.0

                                    The binary package
            names are
                        python-wxgtk4.0 (for
                              Python 2)
                                    and python3-wxgtk4.0
            (for Python 3). 
                        The media
                              module is
                                    packaged separately
            as
                                   
                       
            python-wxgtk-media4.0/python3-wxgtk-media4.0.

                                    These packages have
            also been pulled
                        into the
                              upcoming Ubuntu
                                    18.04 release.

                                    Fedora:
                                    The packages have
            been built in Rawhide
                        and F28
                              development. 
                                    The update to pull
            them into F27 is in
                              updates-testing.  It
                                    should be pushed
            within a week or so.

                                    The package names
            are:
                                    python2-wxpython4
                                   
            python2-wxpython4-media (for python 2
                        media module)
                                   
            python2-wxpython4-webview (for python 2
                        webview
                              module)
                                    python3-wxpython4
                                   
            python3-wxpython4-media (for python 3
                        media module)
                                   
            python3-wxpython4-webview (for python 3
                        webview
                              module)

                                    Note: if you used my
            COPR packages for
                        Fedora, you
                              might
                                    notice that the
            package names are
                        different.  The
                              official
                                    packages should
            obsolete the COPR
                        packages, so those
                              should be
                                    removed.  Then you
            can just remove my
                        COPR from your
                                    repository
            configuration.

                                    Any questions or
            bugs, please let me
                        know.

                                    Scott

                                    --
                                    You received this
            message because you
                        are subscribed
                              to the
                                    Google Groups
            "wxPython-dev" group.
                                    To unsubscribe from
            this group and stop
                        receiving
                              emails from
                                    it, send an email to
                                   
                       
            [hidden email].
                                    For more options,
            visit
                             
            https://groups.google.com/d/optout.


                              --
                              You received this message
            because you are
                        subscribed to
                              the Google Groups
                        "wxPython-users" group.
                        To unsubscribe from this group
            and stop receiving
                        emails from
                        it, send an
                        email to
                       
            [hidden email].
                        For more options, visit
                       
            https://groups.google.com/d/optout.



                        --
                        You received this message because
            you are subscribed
                        to the Google
                        Groups "wxPython-dev" group.
                        To unsubscribe from this group
            and stop receiving
                        emails from it, send
                        an email to
                       
            [hidden email].
                        For more options, visit
                       
            https://groups.google.com/d/optout.


                        --
                        You received this message because
            you are subscribed
                        to the Google Groups
                        "wxPython-dev" group.
                        To unsubscribe from this group
            and stop receiving
                        emails from it, send an
                        email to
            [hidden email].
                        For more options, visit
                       
            https://groups.google.com/d/optout.



                  --
            You received this message because you are
            subscribed to the Google
            Groups "wxPython-dev" group.
            To unsubscribe from this group and stop
            receiving emails from it, send
            an email to
            [hidden email].
            For more options, visit
            https://groups.google.com/d/optout.


            --
            You received this message because you are
            subscribed to the Google Groups
            "wxPython-dev" group.
            To unsubscribe from this group and stop
            receiving emails from it, send an
            email to
            [hidden email].
            For more options, visit
            https://groups.google.com/d/optout.



      --
      You received this message because you are subscribed to
      the Google Groups "wxPython-dev" group.
      To unsubscribe from this group and stop receiving emails
      from it, send an email to
      [hidden email].
      For more options, visit
      https://groups.google.com/d/optout.



--
You received this message because you are subscribed to the Google Groups
"wxPython-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to [hidden email].
For more options, visit https://groups.google.com/d/optout.



--
You received this message because you are subscribed to the Google Groups "wxPython-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.