pypi wheel not working on openSuse 15

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

pypi wheel not working on openSuse 15

john fabiani`
I could use some help with this!  I believe I have everything installed that is required - and I was able to build 4.0.1 - just can't build 4.0.3
Johnf

    *** Could not run GTK+ test program, checking why...
   *** The test program failed to compile or link. See the file config.log for the
   *** exact error that occured. This usually means GTK+ is incorrectly installed.
   configure: error:
   The development files for GTK+ were not found. For GTK+ 2, please
   ensure that pkg-config is in the path and that gtk+-2.0.pc is
   installed. For GTK+ 1.2 please check that gtk-config is in the path,
   and that the version is 1.2.3 or above. Also check that the
   libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
   --libs' are in the LD_LIBRARY_PATH or equivalent.
    
   Error running configure
   ERROR: failed building wxWidgets
   Traceback (most recent call last):
     File "build.py", line 1321, in cmd_build_wx
       wxbuild.main(wxDir(), build_options)
     File "/tmp/pip-install-4nPtoX/wxpython/buildtools/build_wxwidgets.py", line 375, in main
       "Error running configure")
     File "/tmp/pip-install-4nPtoX/wxpython/buildtools/build_wxwidgets.py", line 85, in exitIfError
       raise builder.BuildError(msg)
   BuildError
   Finished command: build_wx (7.230s)
   Finished command: build (7.230s)
   Command '"/u/wx4/wx4test/bin/python" -u build.py build' failed with exit code 1.

--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: pypi wheel not working on openSuse 15

Robin Dunn
On Friday, July 27, 2018 at 10:04:35 AM UTC-7, johnf wrote:
I could use some help with this!  I believe I have everything installed that is required - and I was able to build 4.0.1 - just can't build 4.0.3
Johnf

    *** Could not run GTK+ test program, checking why...
   *** The test program failed to compile or link. See the file config.log for the
   *** exact error that occured. This usually means GTK+ is incorrectly installed.
   configure: error:
   The development files for GTK+ were not found. For GTK+ 2, please
   ensure that pkg-config is in the path and that gtk+-2.0.pc is
   installed. For GTK+ 1.2 please check that gtk-config is in the path,
   and that the version is 1.2.3 or above. Also check that the
   libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
   --libs' are in the LD_LIBRARY_PATH or equivalent.


Did you investigate these suggestions?

--
Robin


--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: pypi wheel not working on openSuse 15

john fabiani`

I ended up finding a better whl file and it worked just fine.  I believe the real issue is that I am using OpenSuse 15 and NOT Ubuntu.

Johnf


On 08/07/2018 11:17 AM, Robin Dunn wrote:
On Friday, July 27, 2018 at 10:04:35 AM UTC-7, johnf wrote:
I could use some help with this!  I believe I have everything installed that is required - and I was able to build 4.0.1 - just can't build 4.0.3
Johnf

    *** Could not run GTK+ test program, checking why...
   *** The test program failed to compile or link. See the file config.log for the
   *** exact error that occured. This usually means GTK+ is incorrectly installed.
   configure: error:
   The development files for GTK+ were not found. For GTK+ 2, please
   ensure that pkg-config is in the path and that gtk+-2.0.pc is
   installed. For GTK+ 1.2 please check that gtk-config is in the path,
   and that the version is 1.2.3 or above. Also check that the
   libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
   --libs' are in the LD_LIBRARY_PATH or equivalent.


Did you investigate these suggestions?

--
Robin


--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.