Installing wxPython on Raspberry Pi 3

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Installing wxPython on Raspberry Pi 3

Keep Secret
 I managed to find - at last - a better install help for the RPi.

 From here : https://wiki.wxpython.org/BuildWxPythonOnRaspberryPi

But after the install with no problems I get:

in the help it states  sudo pip3 install wxPython-4.0.1-cp36-cp36m-linux_armv7l.whl
This is not on the system but

 sudo pip3 install wxPython-4.0.1-cp35-cp35m-linux_armv7l.whl   worked.

Statring the demo.py I got a menu (really good graphics!!) but the following:

i@hostb:~/wxPython-4.0.1/demo $ python demo.py

** (demo.py:2976): CRITICAL **: clearlooks_style_draw_box_gap: assertion 'height >= -1' failed

** (demo.py:2976): CRITICAL **: clearlooks_style_draw_box_gap: assertion 'height >= -1' failed

** (demo.py:2976): CRITICAL **: clearlooks_style_draw_box_gap: assertion 'height >= -1' failed



Since the GUI has suberb graphics I want to stay with wxPython.


Can someone assist here please???

Thanks

NT
 


--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Installing wxPython on Raspberry Pi 3

sebastian lópez
Hello

I've installed wxpython under raspbian and also I ran the demo.py and I've got no problem the only is that tooltip are not working, I recomend you to follow the steps posted in  https://wiki.wxpython.org/BuildWxPythonOnRaspberryPi

In my case I used:

$ sudo apt-get update

$ sudo apt-get install dpkg-dev build-essential libjpeg-dev libtiff-dev libsdl1.2-dev libgstreamer-plugins-base0.10-dev libnotify-dev freeglut3 freeglut3-dev libwebkitgtk-dev

$ cd wxPython-4.0.1

$ python3 build.py build bdist_wheel --jobs=1 --gtk2

$ cd ~/wxPython-4.0.1/dist

$ pip3 install wxPython-4.0.1-cp36-cp36m-linux_armv7l.whl

The compilation time takes to much, at least four hours, but it works

Please try again!


El martes, 10 de abril de 2018, 10:22:49 (UTC-5), Keep Secret escribió:
 I managed to find - at last - a better install help for the RPi.

 From here : <a href="https://wiki.wxpython.org/BuildWxPythonOnRaspberryPi" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwiki.wxpython.org%2FBuildWxPythonOnRaspberryPi\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNELviXJwvs1Blq_VGaMxCa89S6NGQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwiki.wxpython.org%2FBuildWxPythonOnRaspberryPi\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNELviXJwvs1Blq_VGaMxCa89S6NGQ&#39;;return true;">https://wiki.wxpython.org/BuildWxPythonOnRaspberryPi

But after the install with no problems I get:

in the help it states  sudo pip3 install wxPython-4.0.1-cp36-cp36m-linux_armv7l.whl
This is not on the system but

 sudo pip3 install wxPython-4.0.1-cp35-cp35m-linux_armv7l.whl   worked.

Statring the demo.py I got a menu (really good graphics!!) but the following:

i@hostb:~/wxPython-4.0.1/demo $ python demo.py

** (demo.py:2976): CRITICAL **: clearlooks_style_draw_box_gap: assertion 'height >= -1' failed

** (demo.py:2976): CRITICAL **: clearlooks_style_draw_box_gap: assertion 'height >= -1' failed

** (demo.py:2976): CRITICAL **: clearlooks_style_draw_box_gap: assertion 'height >= -1' failed



Since the GUI has suberb graphics I want to stay with wxPython.


Can someone assist here please???

Thanks

NT
 


--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Installing wxPython on Raspberry Pi 3

sebastian lópez
If you prefer you can try the compiled file at

https://sites.google.com/site/sebas2print

and so remember to excecute this

$ sudo apt-get update

$ sudo apt-get install dpkg-dev build-essential libjpeg-dev libtiff-dev libsdl1.2-dev libgstreamer-plugins-base0.10-dev libnotify-dev freeglut3 freeglut3-dev libwebkitgtk-dev

and then install the compiled file in the above link


El martes, 10 de abril de 2018, 11:36:44 (UTC-5), sebastian lópez escribió:
Hello

I've installed wxpython under raspbian and also I ran the demo.py and I've got no problem the only is that tooltip are not working, I recomend you to follow the steps posted in  <a href="https://wiki.wxpython.org/BuildWxPythonOnRaspberryPi" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwiki.wxpython.org%2FBuildWxPythonOnRaspberryPi\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNELviXJwvs1Blq_VGaMxCa89S6NGQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwiki.wxpython.org%2FBuildWxPythonOnRaspberryPi\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNELviXJwvs1Blq_VGaMxCa89S6NGQ&#39;;return true;">https://wiki.wxpython.org/BuildWxPythonOnRaspberryPi

In my case I used:

$ sudo apt-get update

$ sudo apt-get install dpkg-dev build-essential libjpeg-dev libtiff-dev libsdl1.2-dev libgstreamer-plugins-base0.10-dev libnotify-dev freeglut3 freeglut3-dev libwebkitgtk-dev

$ cd wxPython-4.0.1

$ python3 build.py build bdist_wheel --jobs=1 --gtk2

$ cd ~/wxPython-4.0.1/dist

$ pip3 install wxPython-4.0.1-cp36-cp36m-linux_armv7l.whl

The compilation time takes to much, at least four hours, but it works

Please try again!


El martes, 10 de abril de 2018, 10:22:49 (UTC-5), Keep Secret escribió:
 I managed to find - at last - a better install help for the RPi.

 From here : <a href="https://wiki.wxpython.org/BuildWxPythonOnRaspberryPi" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwiki.wxpython.org%2FBuildWxPythonOnRaspberryPi\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNELviXJwvs1Blq_VGaMxCa89S6NGQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwiki.wxpython.org%2FBuildWxPythonOnRaspberryPi\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNELviXJwvs1Blq_VGaMxCa89S6NGQ&#39;;return true;">https://wiki.wxpython.org/BuildWxPythonOnRaspberryPi

But after the install with no problems I get:

in the help it states  sudo pip3 install wxPython-4.0.1-cp36-cp36m-linux_armv7l.whl
This is not on the system but

 sudo pip3 install wxPython-4.0.1-cp35-cp35m-linux_armv7l.whl   worked.

Statring the demo.py I got a menu (really good graphics!!) but the following:

i@hostb:~/wxPython-4.0.1/demo $ python demo.py

** (demo.py:2976): CRITICAL **: clearlooks_style_draw_box_gap: assertion 'height >= -1' failed

** (demo.py:2976): CRITICAL **: clearlooks_style_draw_box_gap: assertion 'height >= -1' failed

** (demo.py:2976): CRITICAL **: clearlooks_style_draw_box_gap: assertion 'height >= -1' failed



Since the GUI has suberb graphics I want to stay with wxPython.


Can someone assist here please???

Thanks

NT
 


--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Installing wxPython on Raspberry Pi 3

Tim Roberts
In reply to this post by Keep Secret
Keep Secret wrote:

 sudo pip3 install wxPython-4.0.1-cp35-cp35m-linux_armv7l.whl   worked.

Statring the demo.py I got a menu (really good graphics!!) but the following:

[hidden email] $ python demo.py

** (demo.py:2976): CRITICAL **: clearlooks_style_draw_box_gap: assertion 'height >= -1' failed
** (demo.py:2976): CRITICAL **: clearlooks_style_draw_box_gap: assertion 'height >= -1' failed
** (demo.py:2976): CRITICAL **: clearlooks_style_draw_box_gap: assertion 'height >= -1' failed


Since the GUI has suberb graphics I want to stay with wxPython.

Many wxWidgets trigger these GTK warnings.  Despite the word "CRITICAL", almost without exception, they can be ignored.

I wish the GTK guys would put these warnings in a log file somewhere so as not to alarm users.
-- 
Tim Roberts, [hidden email]
Providenza & Boekelheide, Inc.

--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Installing wxPython on Raspberry Pi 3

Robin Dunn
On Tuesday, April 10, 2018 at 1:25:28 PM UTC-7, Tim Roberts wrote:
Keep Secret wrote:

 sudo pip3 install wxPython-4.0.1-cp35-cp35m-linux_armv7l.whl   worked.

Statring the demo.py I got a menu (really good graphics!!) but the following:

[hidden email] $ python demo.py

** (demo.py:2976): CRITICAL **: clearlooks_style_draw_box_gap: assertion 'height >= -1' failed
** (demo.py:2976): CRITICAL **: clearlooks_style_draw_box_gap: assertion 'height >= -1' failed
** (demo.py:2976): CRITICAL **: clearlooks_style_draw_box_gap: assertion 'height >= -1' failed


Since the GUI has suberb graphics I want to stay with wxPython.

Many wxWidgets trigger these GTK warnings.  Despite the word "CRITICAL", almost without exception, they can be ignored.

I wish the GTK guys would put these warnings in a log file somewhere so as not to alarm users.


In this case it looks like the asserts are from the active theme, so it is yet another step away from actually being "CRITICAL".

--
Robin

  

--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.