How to get ride of "squares" in the TreeListCtl

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

How to get ride of "squares" in the TreeListCtl

Gabrielle C

I asked the same question on stackoverflow but nobody answered, from what I saw the community i more engaged in forums and groups than in stack...

I am using the following code to create a TreeList:

tree = wx.dataview.TreeListCtrl(self, -1, style=wx.TR_DEFAULT_STYLE | \
                                        wx.TR_FULL_ROW_HIGHLIGHT | \
                                        wx.TR_EDIT_LABELS
tree.AppendColumn("Item Name")
node = tree.AppendItem(parent_node, text)

And for some reason there's an empty square (It looks like a checkbox, but it is not clickable... - see image bellow)

enter image description here

I even tried to add item as this:

node = tree.AppendItem(parent_node, text, wx.NO_IMAGE, wx.NO_IMAGE)

or

node = tree.AppendItem(parent_node, text)
tree.SetItemImage(node, wx.NO_IMAGE, wx.NO_IMAGE)

But none worked, when I remove the wx.TR_DEFAULT_STYLE style, the box is gone, but the space previously occupied remains there...

--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.