4.0.3 build error needs explaining

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

4.0.3 build error needs explaining

Rich Shepard
   I'm setting up a new desktop running Slackware-14.2/x86_64, Python-3.6.6,
the gcc- suite version 5.5.0, glibc- suite version 2.23, wxGTK-2.8.12, and
wxGTK3-3.0.4.

   Building wxPython-3.0.2.0 completed with no errors, but -4.0.3 fails with
these messages:

Waf: Leaving directory `/opt/SBo/wxPython-4.0.3/build/waf/3.6/gtk3'
Build failed
  -> task in '_html2' failed with exit status 1 (run with -v to display more information)
  -> task in '_html2' failed with exit status 1 (run with -v to display more information)
  -> task in '_html2' failed with exit status 1 (run with -v to display more information)
  -> task in '_html2' failed with exit status 1 (run with -v to display more information)
  -> task in '_html2' failed with exit status 1 (run with -v to display more information)
  -> task in '_html2' failed with exit status 1 (run with -v to display more information)
  -> task in '_html2' failed with exit status 1 (run with -v to display more information)
  -> task in '_html2' failed with exit status 1 (run with -v to display more information)
Command '"/usr/bin/python3" /opt/SBo/wxPython-4.0.3/bin/waf-2.0.7 --wx_config=/opt/SBo/wxPython-4.0.3/build/wxbld/gtk3/wx-config --gtk3 --python="/usr/bin/python3" --out=build/waf/3.6/gtk3 configure build ' failed with exit code 1.
Finished command: build_py (3m43.435s)
Finished command: build (5m0.665s)
Command '"/usr/bin/python3" -u build.py build' failed with exit code 1.

   Running the SlackBuild script with an appended '-v' did nothing.

   I'm looking for insights why the build failed, or pointers to a fix.

Rich

--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: 4.0.3 build error needs explaining

Scott Talbert


On October 7, 2018 9:23:17 AM MDT, Rich Shepard <[hidden email]> wrote:

>I'm setting up a new desktop running Slackware-14.2/x86_64,
>Python-3.6.6,
>the gcc- suite version 5.5.0, glibc- suite version 2.23, wxGTK-2.8.12,
>and
>wxGTK3-3.0.4.
>
>Building wxPython-3.0.2.0 completed with no errors, but -4.0.3 fails
>with
>these messages:
>
>Waf: Leaving directory `/opt/SBo/wxPython-4.0.3/build/waf/3.6/gtk3'
>Build failed
>-> task in '_html2' failed with exit status 1 (run with -v to display
>more information)
>-> task in '_html2' failed with exit status 1 (run with -v to display
>more information)
>-> task in '_html2' failed with exit status 1 (run with -v to display
>more information)
>-> task in '_html2' failed with exit status 1 (run with -v to display
>more information)
>-> task in '_html2' failed with exit status 1 (run with -v to display
>more information)
>-> task in '_html2' failed with exit status 1 (run with -v to display
>more information)
>-> task in '_html2' failed with exit status 1 (run with -v to display
>more information)
>-> task in '_html2' failed with exit status 1 (run with -v to display
>more information)
>Command '"/usr/bin/python3" /opt/SBo/wxPython-4.0.3/bin/waf-2.0.7
>--wx_config=/opt/SBo/wxPython-4.0.3/build/wxbld/gtk3/wx-config --gtk3
>--python="/usr/bin/python3" --out=build/waf/3.6/gtk3 configure build '
>failed with exit code 1.
>Finished command: build_py (3m43.435s)
>Finished command: build (5m0.665s)
>Command '"/usr/bin/python3" -u build.py build' failed with exit code 1.
>
>   Running the SlackBuild script with an appended '-v' did nothing.
>
>   I'm looking for insights why the build failed, or pointers to a fix.
>
>Rich

Is that the entirety of the log?  We probably need to see the entire thing to see what went wrong earlier.  My guess, though, given that the failure was with html2, is probably that you're missing the WebKit2 development libraries.  I don't know what the correct package names would be on Slackware though.

Scott

--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: 4.0.3 build error needs explaining

Rich Shepard
On Sun, 7 Oct 2018, Scott Talbert wrote:

> Is that the entirety of the log? We probably need to see the entire thing
> to see what went wrong earlier. My guess, though, given that the failure
> was with html2, is probably that you're missing the WebKit2 development
> libraries. I don't know what the correct package names would be on
> Slackware though.

Scott,

   Slackware does not ship partial applications; there are no separate
development packages, only complete ones. Installed are qt5-webkit and
webkit2gtk. The only requirements for wxPython4 are Python3 and webkit2gtk.
And that's how wxPython4 built on the current desktop.

   Tomorrow I'll tee the output to a build log and upload that to a web site
where it can be downloaded.

Thanks,

Rich

--
You received this message because you are subscribed to the Google Groups "wxPython-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.